summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit_data_models
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/metasploit_data_models
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/metasploit_data_models')
-rw-r--r--dev-ruby/metasploit_data_models/Manifest1
-rw-r--r--dev-ruby/metasploit_data_models/metadata.xml13
-rw-r--r--dev-ruby/metasploit_data_models/metasploit_data_models-0.17.0.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/metasploit_data_models/Manifest b/dev-ruby/metasploit_data_models/Manifest
new file mode 100644
index 00000000000..b6c9b2d9c77
--- /dev/null
+++ b/dev-ruby/metasploit_data_models/Manifest
@@ -0,0 +1 @@
+DIST metasploit_data_models-0.17.0.tar.gz 93759 SHA256 ce24d5ac6ff4e60dd04ed82c9e7821617c1234d32c7e6708573fc5a36942532f SHA512 0ca1556d6c8b8a83abd4bad2641d795979e5c7df8bd226ea9be6024df7bb71cec0e5434126a33e09842618a6df1e6dbec0d9049bd4997f3042b063c413e50c69 WHIRLPOOL 224e873f2457cbbd6a142fc28b0076cb325382055a3fcbd20107fc3d439e3ce2cf28e3007517fec7b6537a58194322497bc98342b6d11d4b3a051355a10b6965
diff --git a/dev-ruby/metasploit_data_models/metadata.xml b/dev-ruby/metasploit_data_models/metadata.xml
new file mode 100644
index 00000000000..adbce01fd10
--- /dev/null
+++ b/dev-ruby/metasploit_data_models/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/metasploit_data_models</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit_data_models/metasploit_data_models-0.17.0.ebuild b/dev-ruby/metasploit_data_models/metasploit_data_models-0.17.0.ebuild
new file mode 100644
index 00000000000..69ac28f2ac7
--- /dev/null
+++ b/dev-ruby/metasploit_data_models/metasploit_data_models-0.17.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Tests depend on unpackaged factory_girl_rails
+RUBY_FAKEGEM_RECIPE_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="app db script spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The database layer for Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit_data_models"
+SRC_URI="https://github.com/rapid7/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activerecord-3.2.10[postgres]
+ dev-ruby/activesupport"