summaryrefslogtreecommitdiff
path: root/dev-ruby/mimemagic
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mimemagic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mimemagic')
-rw-r--r--dev-ruby/mimemagic/Manifest1
-rw-r--r--dev-ruby/mimemagic/metadata.xml8
-rw-r--r--dev-ruby/mimemagic/mimemagic-0.3.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/mimemagic/Manifest b/dev-ruby/mimemagic/Manifest
new file mode 100644
index 00000000000..10f2e919a99
--- /dev/null
+++ b/dev-ruby/mimemagic/Manifest
@@ -0,0 +1 @@
+DIST mimemagic-0.3.0.gem 354816 SHA256 a9a1de1e5750b4e59d1126a84dd67ae55595feda835f1659e3fe686917c13480 SHA512 ce65aedf83a281d6369f670001d865046480362bfee17ac5cce9b2775affeeb3cf50552abab0eca6300b7f80d6f6226926f464e1b0b69a09adff2a174ba609fe WHIRLPOOL 78c6d18379e6b6e2f109232744be48062e224c179e6b965ed08b5a1ea8148b1b03f10cbea05a7d00c1c9df6dd14e51ea04609e3ec11797168fe3b49dd32ff59a
diff --git a/dev-ruby/mimemagic/metadata.xml b/dev-ruby/mimemagic/metadata.xml
new file mode 100644
index 00000000000..9617d6abb1b
--- /dev/null
+++ b/dev-ruby/mimemagic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">minad/mimemagic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mimemagic/mimemagic-0.3.0.ebuild b/dev-ruby/mimemagic/mimemagic-0.3.0.ebuild
new file mode 100644
index 00000000000..be44373f99f
--- /dev/null
+++ b/dev-ruby/mimemagic/mimemagic-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast mime detection by extension or content"
+HOMEPAGE="https://github.com/minad/mimemagic"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -q -Ilib:test test/*_test.rb || die
+}