summaryrefslogtreecommitdiff
path: root/dev-ruby/mini_magick
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mini_magick
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mini_magick')
-rw-r--r--dev-ruby/mini_magick/Manifest2
-rw-r--r--dev-ruby/mini_magick/metadata.xml8
-rw-r--r--dev-ruby/mini_magick/mini_magick-4.2.7.ebuild49
-rw-r--r--dev-ruby/mini_magick/mini_magick-4.2.9.ebuild45
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-ruby/mini_magick/Manifest b/dev-ruby/mini_magick/Manifest
new file mode 100644
index 00000000000..32493bc5aec
--- /dev/null
+++ b/dev-ruby/mini_magick/Manifest
@@ -0,0 +1,2 @@
+DIST mini_magick-4.2.7.tar.gz 1059704 SHA256 55c829cbbc09020a7e48864374341b09c25700f343e6f443248bf99b906ed88c SHA512 172e71d3d9286d92541951d83a67e3be05ff207e27502472426fab10ca92339c371f52ca85790300bdb881b10470ed7810e01a85d3b4e1a2ed4e89dc0f117493 WHIRLPOOL 90d8a7544d11699724b873b30cdc9243d5c388ddb4216577119770ea38ac1d336a5af2853861a9a6dd957f1f0a17af363446882ebaae19853f20dbf10398f66e
+DIST mini_magick-4.2.9.tar.gz 1059967 SHA256 f168e4683a38209ec0298d94678b493c793fb785e657d850a08dff3ab461464e SHA512 d3ffc33d14030b27d106930dbf7183eb7884646103f063361e798670929c37bac36bed08cfd4e9c6128c51f8c6b05a3e2eeb440d01abe7f0b788211ede4e4c26 WHIRLPOOL cf5e7d76105f2d446917eea3596d6b4413700aa202e4124b29a233371125a397251ef2bdb3d7ee8f66272bf584e18933510e7290bf7c7d9a6f1f26d6991e1dd1
diff --git a/dev-ruby/mini_magick/metadata.xml b/dev-ruby/mini_magick/metadata.xml
new file mode 100644
index 00000000000..6c62a349f10
--- /dev/null
+++ b/dev-ruby/mini_magick/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">minimagick/minimagick</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mini_magick/mini_magick-4.2.7.ebuild b/dev-ruby/mini_magick/mini_magick-4.2.7.ebuild
new file mode 100644
index 00000000000..2d07ad49d15
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-4.2.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory"
+HOMEPAGE="https://github.com/minimagick/minimagick"
+SRC_URI="https://github.com/minimagick/minimagick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="minimagick-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND+=" media-gfx/imagemagick"
+DEPEND+=" test? ( media-gfx/imagemagick[tiff,jpeg,png] >=media-gfx/graphicsmagick-1.3.20[tiff,jpeg,png] )"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/posix-spawn )"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ sed -i -e '/\([Bb]undler\|pry\)/ s:^:#:' spec/spec_helper.rb || die
+
+ # Don't force a specific formatter but use overall Gentoo defaults.
+ sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
+
+ # Avoid test depending on graphicsmagick
+ sed -e '/identifies when gm exists/,/^ end/ s:^:#:' \
+ -i spec/lib/mini_magick_spec.rb || die
+}
diff --git a/dev-ruby/mini_magick/mini_magick-4.2.9.ebuild b/dev-ruby/mini_magick/mini_magick-4.2.9.ebuild
new file mode 100644
index 00000000000..4de4e097e0e
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-4.2.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory"
+HOMEPAGE="https://github.com/minimagick/minimagick"
+SRC_URI="https://github.com/minimagick/minimagick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="minimagick-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND+=" media-gfx/imagemagick"
+DEPEND+=" test? ( media-gfx/imagemagick[tiff,jpeg,png] >=media-gfx/graphicsmagick-1.3.20[tiff,jpeg,png] )"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/posix-spawn )"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ sed -i -e '/\([Bb]undler\|pry\)/ s:^:#:' spec/spec_helper.rb || die
+
+ # Don't force a specific formatter but use overall Gentoo defaults.
+ sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
+}