summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-pipeline
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-01-24 13:23:31 -0700
committerChristoph Junghans <ottxor@gentoo.org>2016-02-06 16:32:25 -0700
commit0cfd2babf6ae9e5359785df42275633705bead43 (patch)
tree7387848ce286df58aa5a45e3b72fa7b4bd358822 /dev-ruby/net-http-pipeline
parent12a3311954f3533b6fb02b404ff81401d9d8e390 (diff)
downloadgentoo-0cfd2babf6ae9e5359785df42275633705bead43.tar.gz
gentoo-0cfd2babf6ae9e5359785df42275633705bead43.tar.xz
dev-ruby/net-http-pipeline: initial commit
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/Manifest1
-rw-r--r--dev-ruby/net-http-pipeline/metadata.xml11
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/net-http-pipeline/Manifest b/dev-ruby/net-http-pipeline/Manifest
new file mode 100644
index 00000000000..9e2d62cddc7
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/Manifest
@@ -0,0 +1 @@
+DIST net-http-pipeline-1.0.1.gem 12800 SHA256 6923ce2f28bfde589a9f385e999395eead48ccfe4376d4a85d9a77e8c7f0b22f SHA512 1377c20038176f6c246a7d4adbce2c6972970d730902f9faefc31b2f6446f4237603f45f0f59de70eb9545e3c1e150fe6e63cf350551203166611bef7845f4e2 WHIRLPOOL 691e995dbe5f3fc4605923511f0bea634f5a3558acb629b3694ffe5757392f8943c5c070b814f2a442c1cc3fefa89fd4f3da08773aae340e0b2b7bcfd2769be8
diff --git a/dev-ruby/net-http-pipeline/metadata.xml b/dev-ruby/net-http-pipeline/metadata.xml
new file mode 100644
index 00000000000..59da3fd2d7d
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">drbrain/net-http-pipeline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
new file mode 100644
index 00000000000..f9cfa202eab
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
+HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ test? ( dev-ruby/minitest )
+"