summaryrefslogtreecommitdiff
path: root/dev-ruby/net-ssh
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/net-ssh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/net-ssh')
-rw-r--r--dev-ruby/net-ssh/Manifest3
-rw-r--r--dev-ruby/net-ssh/metadata.xml8
-rw-r--r--dev-ruby/net-ssh/net-ssh-2.10.0.ebuild31
-rw-r--r--dev-ruby/net-ssh/net-ssh-2.8.0.ebuild31
-rw-r--r--dev-ruby/net-ssh/net-ssh-2.9.2.ebuild31
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-ruby/net-ssh/Manifest b/dev-ruby/net-ssh/Manifest
new file mode 100644
index 00000000000..484aa31b733
--- /dev/null
+++ b/dev-ruby/net-ssh/Manifest
@@ -0,0 +1,3 @@
+DIST net-ssh-git-2.10.0.tgz 172885 SHA256 ef063f3f967ec614df49acd74ede7694124f7ffc28c20c7434ac3841c181429a SHA512 f66db6465667baf0c253868cc15aab3261675a8c15ca4b244c3cd587ae5e8b7a273959b97d5fc498ff1b19e1f06f51ea571573d243366a59ef56faf41c2ae347 WHIRLPOOL 1460082033e0cef7dc6ddb2a645943039c0619573701c25fd6e0f784b596b8010142eef295e7df84a30f4239c8da743c500571ed557081b72d5a0212ffb8e9d0
+DIST net-ssh-git-2.8.0.tgz 164483 SHA256 313c63f205f72469aa48d25690b8f98c14cbe0bf90ed2d577191599d609a5b4f SHA512 b16394cdd8d0e3c92f5b22fc882615ef7309606b5d8a413711dda9b76f628c74bc29bad96f0166d31d9de55c14bed1df178053e2d8afa47d78d5d8053e70a631 WHIRLPOOL 1dc057363d847df650e8e704f50bbbe095859f4bda1e617c86f234da28bfbaf57ea5a65ea9b48ea3c999e0dc02a7345bb6a060820509f75bb17aeb6aa521963a
+DIST net-ssh-git-2.9.2.tgz 170078 SHA256 5a657655c76feeb22e726ca54e9d422ed2a7825bedf64c505b4765c6f8ef3105 SHA512 c60ccbf8bc387405c36c230ba4702400841e5f6cc19c99b17d6eba86e97cc65f853839fa322d8f70654bbdb2a2be9ffa5952ab2cab25bb90ed76f54711091206 WHIRLPOOL 29d4780129f77582c2d702c784fa1b1b6c57fae88e4f93401031496abf03e590d10623854767d813cfe60e3f40fb7dc24d162256425691d2d69fb0c77287da30
diff --git a/dev-ruby/net-ssh/metadata.xml b/dev-ruby/net-ssh/metadata.xml
new file mode 100644
index 00000000000..b917e626272
--- /dev/null
+++ b/dev-ruby/net-ssh/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">net-ssh/net-ssh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-ssh/net-ssh-2.10.0.ebuild b/dev-ruby/net-ssh/net-ssh-2.10.0.ebuild
new file mode 100644
index 00000000000..61f2c528f1e
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-2.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-ssh"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die "Tests failed."
+}
diff --git a/dev-ruby/net-ssh/net-ssh-2.8.0.ebuild b/dev-ruby/net-ssh/net-ssh-2.8.0.ebuild
new file mode 100644
index 00000000000..0b27f3e39ef
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-2.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# no longer compatible with ruby 1.8.
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="http://net-ssh.rubyforge.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2.6"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die "Tests failed."
+}
diff --git a/dev-ruby/net-ssh/net-ssh-2.9.2.ebuild b/dev-ruby/net-ssh/net-ssh-2.9.2.ebuild
new file mode 100644
index 00000000000..492cbdc6264
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-2.9.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="http://net-ssh.rubyforge.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die "Tests failed."
+}