summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-08 07:41:30 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-08 07:41:30 +0100
commit70e38454582902c81d4a3f927fc13adaaabb2084 (patch)
treebe22b700e817e2543b7e9097364760c80a4d0f50 /dev-ruby/oauth2
parent880cc3b35613996a11e096c1ce1a0a62aa3adc34 (diff)
downloadgentoo-70e38454582902c81d4a3f927fc13adaaabb2084.tar.gz
gentoo-70e38454582902c81d4a3f927fc13adaaabb2084.tar.xz
dev-ruby/oauth2: add 1.1.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest1
-rw-r--r--dev-ruby/oauth2/oauth2-1.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 0390024fd8c..8b821aad2cc 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1 +1,2 @@
DIST oauth2-1.0.0.gem 21504 SHA256 1925847287bba3d19b0755820f8eef86198754dfa9f77ad53063ffb82d3e4a7d SHA512 80e30c444ffb31a4a2e49a4851bcc0cdf907e9b24c38a6e5f580054ab70df89c951f6e05dec3e9e8b7f1d68ca332b6970fba350d7d309e8a0e6212ff1bafb31c WHIRLPOOL 993b648722f1fbe198339b94c702499de49c6e526358195db822d0ab21c8300b6cacf4af14c4c85e08cf9fc97ea074f196cee06d4b3ce19511aa871c9a450653
+DIST v1.1.0.tar.gz 18376 SHA256 ea76a41dc7c559f9530e19961b5a8cd9a4b3f231f54901b9e6ef09031ce3aa77 SHA512 c4231093929733a662ed6246338508396eb0e8d1be48bff05c43a8e3f6dd38261667cad7db0dc44c3f6fd9152165b13fa46a779a05b3c1ae98f912f337820d2e WHIRLPOOL 0f9269df95ceabbcff65751d89bac5eef6bb18f34114b3045ac658325e7b8145f23fad311473c77e64f3170c45ccc880eb48c05ad6f174c7a42591995498a557
diff --git a/dev-ruby/oauth2/oauth2-1.1.0.ebuild b/dev-ruby/oauth2/oauth2-1.1.0.ebuild
new file mode 100644
index 00000000000..de1e4a7a709
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://github.com/intridea/oauth2"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:*"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}