summaryrefslogtreecommitdiff
path: root/dev-ruby/packetfu
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/packetfu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/packetfu')
-rw-r--r--dev-ruby/packetfu/Manifest2
-rw-r--r--dev-ruby/packetfu/files/packetfu-1.1.10-ruby2x-encoding.patch49
-rw-r--r--dev-ruby/packetfu/metadata.xml11
-rw-r--r--dev-ruby/packetfu/packetfu-1.1.10-r1.ebuild30
-rw-r--r--dev-ruby/packetfu/packetfu-1.1.9.ebuild19
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-ruby/packetfu/Manifest b/dev-ruby/packetfu/Manifest
new file mode 100644
index 00000000000..fe57e8bd21e
--- /dev/null
+++ b/dev-ruby/packetfu/Manifest
@@ -0,0 +1,2 @@
+DIST packetfu-1.1.10.gem 750080 SHA256 7c929b03255b4320598a9bed7c86076435cedb9b7292cb1acab05c4d085c5b22 SHA512 6912d8923eaf596fccb5881025259f8df2494c5ff424a9fe2d4fc28b135c26a89afa8e663dcca97f42ead0c0da14f659611f12472dabe29b26e202c4f79737f9 WHIRLPOOL ccbe1aace3a954972b1e4ff55fcf37e6b686c6074df08f853aa02693b35627a44d01be6e43f0d8ee85a1585b230fde62ba265dade7aabd197430f15a9940d648
+DIST packetfu-1.1.9.gem 750592 SHA256 dc035e2be9312bc6e78ac75951c7af8358304a7b4efa6f82fc07821bf30bd409 SHA512 c032ee9f90d03b5cc588d712f3c1dfe9f797c7c7799fae22c565915cf3ff90962927cb9986cc10b4901549a39a6515a4b2d33f67e7eb23b6a7e0ae3cce750442 WHIRLPOOL 1b58159d54c7df134509065012a4fbf6350d6d3c6c35f1ee44c0fedf7d98925bdb289e07ae44c32e1e9cd5257faff6906c59cc0af31f46cf919fe39900c9b490
diff --git a/dev-ruby/packetfu/files/packetfu-1.1.10-ruby2x-encoding.patch b/dev-ruby/packetfu/files/packetfu-1.1.10-ruby2x-encoding.patch
new file mode 100644
index 00000000000..7d21833757b
--- /dev/null
+++ b/dev-ruby/packetfu/files/packetfu-1.1.10-ruby2x-encoding.patch
@@ -0,0 +1,49 @@
+From ba3ef1af81b494248db230b4f7fdcc155fe256d5 Mon Sep 17 00:00:00 2001
+From: Jonathan Claudius <jclaudius@trustwave.com>
+Date: Sat, 5 Apr 2014 22:15:00 -0400
+Subject: [PATCH] Fix encoding issues in specs for Ruby 2.x
+
+---
+ spec/structfu_spec.rb | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/spec/structfu_spec.rb b/spec/structfu_spec.rb
+index c48c856..84b7e22 100644
+--- a/spec/structfu_spec.rb
++++ b/spec/structfu_spec.rb
+@@ -78,7 +78,7 @@ class StructClass
+ @int.to_s.should == "\x02"
+ @int.read(254)
+ @int.to_i.should == 254
+- @int.to_s.should == "\xfe"
++ @int.to_s.should == "\xfe".force_encoding("binary")
+ end
+
+ end
+@@ -98,7 +98,7 @@ class StructClass
+ end
+
+ it "should print a two character packed string" do
+- @int.to_s.should == "\x00\x0b"
++ @int.to_s.should == "\x00\x0b".force_encoding("binary")
+ end
+
+ it "should have a value of 11" do
+@@ -113,7 +113,7 @@ class StructClass
+ @int.to_s.should == "\x00\x02"
+ @int.read(254)
+ @int.to_i.should == 254
+- @int.to_s.should == "\x00\xfe"
++ @int.to_s.should == "\x00\xfe".force_encoding("binary")
+ end
+
+ it "should be able to set endianness" do
+@@ -198,7 +198,7 @@ class StructClass
+ @int.to_s.should == "\x00\x00\x00\x02"
+ @int.read(254)
+ @int.to_i.should == 254
+- @int.to_s.should == "\x00\x00\x00\xfe"
++ @int.to_s.should == "\x00\x00\x00\xfe".force_encoding("binary")
+ end
+
+ it "should be able to set endianness" do
diff --git a/dev-ruby/packetfu/metadata.xml b/dev-ruby/packetfu/metadata.xml
new file mode 100644
index 00000000000..67d8219afee
--- /dev/null
+++ b/dev-ruby/packetfu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/packetfu/packetfu-1.1.10-r1.ebuild b/dev-ruby/packetfu/packetfu-1.1.10-r1.ebuild
new file mode 100644
index 00000000000..f1d5b3a21e2
--- /dev/null
+++ b/dev-ruby/packetfu/packetfu-1.1.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A mid-level packet manipulation library"
+HOMEPAGE="https://rubygems.org/gems/packetfu"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+ruby_add_rdepend " >=dev-ruby/pcaprub-0.9.2"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-ruby2x-encoding.patch )
+
+all_ruby_prepare() {
+ # Broken for version numbers with multiple digits...
+ sed -i -e '/reports a version number/,/end/ s:^:#:' spec/packetfu_spec.rb || die
+}
diff --git a/dev-ruby/packetfu/packetfu-1.1.9.ebuild b/dev-ruby/packetfu/packetfu-1.1.9.ebuild
new file mode 100644
index 00000000000..a63e4f3b241
--- /dev/null
+++ b/dev-ruby/packetfu/packetfu-1.1.9.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby21"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A mid-level packet manipulation library"
+HOMEPAGE="https://rubygems.org/gems/packetfu"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+ruby_add_rdepend " >=dev-ruby/pcaprub-0.9.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.6.2 )
+ doc? ( >=dev-ruby/sdoc-0.2.0 )"