summaryrefslogtreecommitdiff
path: root/dev-ruby/parslet
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/parslet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/parslet')
-rw-r--r--dev-ruby/parslet/Manifest3
-rw-r--r--dev-ruby/parslet/metadata.xml8
-rw-r--r--dev-ruby/parslet/parslet-1.6.1.ebuild35
-rw-r--r--dev-ruby/parslet/parslet-1.6.2.ebuild34
-rw-r--r--dev-ruby/parslet/parslet-1.7.0.ebuild33
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-ruby/parslet/Manifest b/dev-ruby/parslet/Manifest
new file mode 100644
index 00000000000..0623ef80433
--- /dev/null
+++ b/dev-ruby/parslet/Manifest
@@ -0,0 +1,3 @@
+DIST parslet-1.6.1.tar.gz 236653 SHA256 cedb3aa719914e8ee7902932dd5833de21472831c81917aa480b59e131795816 SHA512 1467a958d7c5e5c6c52d170aa3815c9d87adc8d0f3522e41c0e3d7ae8af43573a960ae1875c75def0d5eddedc35b44e4a89173d00307c1a761b0732fcb46c7c8 WHIRLPOOL 22775d067a2929c971d3db34ab0254ea539c29b2eaa5695546ab9cd66b232e9a2a92046dd5923519f3bb793259de1f856ed00954889d4aedddb57f74661a4ba1
+DIST parslet-1.6.2.tar.gz 237637 SHA256 9ecba337984770838624d2fe0cd75eca41a1c16c4dc9fff6171b5492466e2405 SHA512 a686b41b006c933617ec23d07320882b9ce65f9af73e4065d3e106639f07174e138dfa6654ba00d2c57fd062f26d801c9e6eb21b1d08a7df442d9ea39fa94bf9 WHIRLPOOL 259d70a8f9468ccca765c8f837a2ad68253b4324cf485ca2fab1a60ae31c25e8b2c0c25f17a8ef7c16a0fb62601bbeecd441e480aedf95ccb9b1c7a058f9032a
+DIST parslet-1.7.0.tar.gz 240360 SHA256 9deb7d7191d405c9469ae8ffc224648e7472f2ac0491053f882eff7373f527a4 SHA512 6fa6f9951f68d0d75076c27bf243a65c59d0f18ebec7b5ea9dbdbcc2082f3afda20feb174ac8dd0f84e6bd4f7bea0e573d3c1643d239fbf93275523f07e2d318 WHIRLPOOL f26251068d81f623b8c37b839d6c157bf6bf186417e127f5e7fe36601547c60e69f057929eb402ff7ef065f36bb2972341ea8d9f18d26da34dda7af2cea7ef1d
diff --git a/dev-ruby/parslet/metadata.xml b/dev-ruby/parslet/metadata.xml
new file mode 100644
index 00000000000..9d67314a70a
--- /dev/null
+++ b/dev-ruby/parslet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">kschiess/parslet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/parslet/parslet-1.6.1.ebuild b/dev-ruby/parslet/parslet-1.6.1.ebuild
new file mode 100644
index 00000000000..24d93a52d88
--- /dev/null
+++ b/dev-ruby/parslet/parslet-1.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small PEG based parser library"
+HOMEPAGE="https://github.com/kschiess/parslet"
+SRC_URI="https://github.com/kschiess/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "dev-ruby/blankslate:2"
+
+all_ruby_prepare() {
+ sed -i -e "/sdoc/d" Rakefile || die
+
+ # Make sure correct version of blankslate is used without bundler
+ sed -i -e '1igem "blankslate", "~> 2.0"' spec/spec_helper.rb || die
+
+ # Avoid spec calling out to ruby since we can't guarantee the
+ # correct version of blankslate in this case.
+ rm spec/acceptance/examples_spec.rb || die
+}
diff --git a/dev-ruby/parslet/parslet-1.6.2.ebuild b/dev-ruby/parslet/parslet-1.6.2.ebuild
new file mode 100644
index 00000000000..ab275eeca65
--- /dev/null
+++ b/dev-ruby/parslet/parslet-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small PEG based parser library"
+HOMEPAGE="https://github.com/kschiess/parslet"
+SRC_URI="https://github.com/kschiess/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/blankslate-2"
+
+ruby_add_bdepend "test? ( dev-ruby/flexmock )"
+
+all_ruby_prepare() {
+ sed -i -e "/sdoc/d" Rakefile || die
+ sed -i -e "/unless respond_to?(:failure_message)/,+3d" -e "s/failure_message do/failure_message_for_should do/" spec/parslet/pattern_spec.rb
+ # Avoid spec calling out to ruby since we can't guarantee the
+ # correct version of blankslate in this case.
+ rm spec/acceptance/examples_spec.rb || die
+}
diff --git a/dev-ruby/parslet/parslet-1.7.0.ebuild b/dev-ruby/parslet/parslet-1.7.0.ebuild
new file mode 100644
index 00000000000..1c20aa9ed13
--- /dev/null
+++ b/dev-ruby/parslet/parslet-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small PEG based parser library"
+HOMEPAGE="https://github.com/kschiess/parslet"
+SRC_URI="https://github.com/kschiess/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/blankslate-2"
+
+ruby_add_bdepend "test? ( dev-ruby/flexmock )"
+
+all_ruby_prepare() {
+ sed -i -e "/sdoc/d" Rakefile || die
+ # Avoid spec calling out to ruby since we can't guarantee the
+ # correct version of blankslate in this case.
+ rm spec/acceptance/examples_spec.rb || die
+}