summaryrefslogtreecommitdiff
path: root/dev-ruby/pcaprub
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/pcaprub
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/pcaprub')
-rw-r--r--dev-ruby/pcaprub/Manifest2
-rw-r--r--dev-ruby/pcaprub/metadata.xml11
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild34
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.12.0.ebuild34
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-ruby/pcaprub/Manifest b/dev-ruby/pcaprub/Manifest
new file mode 100644
index 00000000000..349da975399
--- /dev/null
+++ b/dev-ruby/pcaprub/Manifest
@@ -0,0 +1,2 @@
+DIST pcaprub-0.11.3.gem 32768 SHA256 a6f724ce8fe1036a399cefe1c77d3b989cb335e31f078028160c8f875e576eef SHA512 0ac8b5b2be85a2e17dd9f253ae3705a9faca390cefbaeae737ba20a23a3e2d95a6d492d5f7b3ecac611361a264db43cc79fddfbab58056e7de8e075fb1d1ef4f WHIRLPOOL 5a65eb697aebb6282038c98c3bd121ec1eeeca56dc0633d5c5823a798f1a0b2ca11c5f40c95f1fe00481452164a74372fdad6341c812a82165d7106480552bbb
+DIST pcaprub-0.12.0.gem 34816 SHA256 6e5caacc1330df5238985f0c2a45e2d3a3bcbac02218551f6ebdee6df9c7af0f SHA512 5b37e01b4e93d7dc7a9e28c707b9333d0b92cfc27d0bf4af88e1478351d9eb8117d74c5c0a302e5094fd5cc39fa4fb5c962637fd9bfb09efb6fd44dc3a6b5771 WHIRLPOOL 6764e6584e6fd9466cc6823872713ec32f3bc3ec1dcd4d27cb5de812c1eb7b289f38ef8db39ee620b3aa55c1e028aa1a0f4df648ef1e3e17587fed36cdeb28ec
diff --git a/dev-ruby/pcaprub/metadata.xml b/dev-ruby/pcaprub/metadata.xml
new file mode 100644
index 00000000000..67d8219afee
--- /dev/null
+++ b/dev-ruby/pcaprub/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild b/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild
new file mode 100644
index 00000000000..3975d221621
--- /dev/null
+++ b/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Libpcap bindings for ruby compat"
+HOMEPAGE="https://rubygems.org/gems/pcaprub"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND+="net-libs/libpcap"
+RDEPEND+="net-libs/libpcap"
+
+# Tests require live access to a network device as root.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/${PN} V=1
+ cp ext/${PN}/${PN}$(get_modname) lib || die
+}
diff --git a/dev-ruby/pcaprub/pcaprub-0.12.0.ebuild b/dev-ruby/pcaprub/pcaprub-0.12.0.ebuild
new file mode 100644
index 00000000000..991ddc7b999
--- /dev/null
+++ b/dev-ruby/pcaprub/pcaprub-0.12.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Libpcap bindings for ruby compat"
+HOMEPAGE="https://rubygems.org/gems/pcaprub"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND+="net-libs/libpcap"
+RDEPEND+="net-libs/libpcap"
+
+# Tests require live access to a network device as root.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/pcaprub_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/pcaprub_c V=1
+ cp ext/pcaprub_c/pcaprub_c$(get_modname) lib || die
+}