summaryrefslogtreecommitdiff
path: root/dev-ruby/pry
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/pry
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/pry')
-rw-r--r--dev-ruby/pry/Manifest2
-rw-r--r--dev-ruby/pry/metadata.xml8
-rw-r--r--dev-ruby/pry/pry-0.10.1.ebuild50
-rw-r--r--dev-ruby/pry/pry-0.9.12.6-r1.ebuild46
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/pry/Manifest b/dev-ruby/pry/Manifest
new file mode 100644
index 00000000000..6d64fbdd646
--- /dev/null
+++ b/dev-ruby/pry/Manifest
@@ -0,0 +1,2 @@
+DIST pry-0.10.1.tar.gz 204021 SHA256 c04af53883e742d6cf44c3923a6e397b14f14520f73da0d3f68dfc0855e8645b SHA512 cbb850d5bc9012da376ed87a894c939e20f0c1992565e3f9c282a85fd3026c2eb71a487672e2dc141a8f1ac0016f467782448e318012ef761e5cc21edb376b92 WHIRLPOOL 1b320e9e6956121b4b51d9d56b09deec823e00b3384b74065047bf2c32fc7d145bb34e63906cd1b0093f160c3e7b5a449f1ae1cecaeed5d36a388cb053786780
+DIST pry-0.9.12.6.gem 198144 SHA256 0107730b35bdd4fd042fa9c92263174a38f975844230bc5c583fd4816c55af72 SHA512 451da80d9224f3c826bdcb0492d1880005143ae489dc1de0021ed73fd3d34ef3bab7c06dd631cf9737c7b4d9b031d1ee7be05c4e4d99ab9af24231ce388ac3b9 WHIRLPOOL c04d80c3e2a357dbdab549be0d5b83ce319dcfbac286dd5b7e156e1a800cd87d89974a5213e8fb0860819a606a5633295ed0b645ab049a68674cf68a2d1a947d
diff --git a/dev-ruby/pry/metadata.xml b/dev-ruby/pry/metadata.xml
new file mode 100644
index 00000000000..83b59f44689
--- /dev/null
+++ b/dev-ruby/pry/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">pry/pry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pry/pry-0.10.1.ebuild b/dev-ruby/pry/pry-0.10.1.ebuild
new file mode 100644
index 00000000000..9fe5aaa1077
--- /dev/null
+++ b/dev-ruby/pry/pry-0.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> test failure
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.1.0
+ >=dev-ruby/slop-3.4.1:3
+ >=dev-ruby/method_source-0.8"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-1.0
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -e '/coderay/s/~>/>=/' \
+ -e '/bundler/d' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/[Bb]undler/d' -e "1irequire 'mocha/api'\ " -i spec/helper.rb || die
+ sed -e "1irequire 'ostruct'\ " -i spec/hooks_spec.rb || die
+ sed -e '/of Class after the singleton classes/,+4d' -i spec/method_spec.rb || die
+ # Out of date tests
+ rm spec/commands/gist_spec.rb || die
+}
diff --git a/dev-ruby/pry/pry-0.9.12.6-r1.ebuild b/dev-ruby/pry/pry-0.9.12.6-r1.ebuild
new file mode 100644
index 00000000000..3177c736503
--- /dev/null
+++ b/dev-ruby/pry/pry-0.9.12.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.0.5
+ >=dev-ruby/slop-3.4.1:3
+ >=dev-ruby/method_source-0.8"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/bacon-1.2
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-0.13.1
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -e '/coderay/s/~>/>=/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ispec -q spec/*_spec.rb spec/*/*_spec.rb || die
+}