summaryrefslogtreecommitdiff
path: root/dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-02-23 13:37:37 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-02-23 13:55:32 -0600
commitac888a58365252312f6fa0038568131f5eef22c7 (patch)
tree50c02d5c891c32ad7c94ef11cace593768cea88d /dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild
parent3f75cba317d5fae3b2035d5b55b68be2e87cff01 (diff)
downloadgentoo-ac888a58365252312f6fa0038568131f5eef22c7.tar.gz
gentoo-ac888a58365252312f6fa0038568131f5eef22c7.tar.xz
dev-ruby/puppetdb-termini: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild
new file mode 100644
index 00000000000..98635dbc191
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-3.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/puppetdb/${PN}_${PV}-1puppetlabs1_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}