summaryrefslogtreecommitdiff
path: root/dev-ruby/radius
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-25 07:46:11 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-25 07:46:11 +0200
commit758d093c9a1c702fdfc333e1c6d97808a13eb870 (patch)
tree5d11f169e671c239abea8879e534e2f83296870d /dev-ruby/radius
parent409290604180d0c9016a4ccd41da792f30358b00 (diff)
downloadgentoo-758d093c9a1c702fdfc333e1c6d97808a13eb870.tar.gz
gentoo-758d093c9a1c702fdfc333e1c6d97808a13eb870.tar.xz
dev-ruby/radius: add ruby23
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/radius')
-rw-r--r--dev-ruby/radius/radius-0.7.4-r4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/radius/radius-0.7.4-r4.ebuild b/dev-ruby/radius/radius-0.7.4-r4.ebuild
new file mode 100644
index 00000000000..c70bc37c1a4
--- /dev/null
+++ b/dev-ruby/radius/radius-0.7.4-r4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG QUICKSTART.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Powerful tag-based template system"
+HOMEPAGE="https://github.com/jlong/radius http://radius.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/kramdown )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/d" -e "/coveralls/d" test/test_helper.rb || die
+}