summaryrefslogtreecommitdiff
path: root/dev-ruby/rails-dom-testing
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rails-dom-testing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rails-dom-testing')
-rw-r--r--dev-ruby/rails-dom-testing/Manifest2
-rw-r--r--dev-ruby/rails-dom-testing/metadata.xml8
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-1.0.5.ebuild27
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-1.0.6.ebuild27
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/Manifest b/dev-ruby/rails-dom-testing/Manifest
new file mode 100644
index 00000000000..a65c3dca9d4
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/Manifest
@@ -0,0 +1,2 @@
+DIST rails-dom-testing-1.0.5.gem 16896 SHA256 35a6b222f33e98bc8c0401cea57aaf155c5a7ab75748e219071538dd096f6f13 SHA512 49b363f89a21af84f4f502284dc4802de2c324f4129c6653c96b548bacd35492b1ca11ae6d631cfc3b777f66ab2cbcccfa9714e7971221ddecd7d296441f6b14 WHIRLPOOL a9f04238acde83b174e85c315d48a4f416eaa08ba07461093dd9fd5abb3dab4213c119d493009489dc8cea203300684fd5c36f811e6ede66c8800f54bf8150a0
+DIST rails-dom-testing-1.0.6.gem 17408 SHA256 a7b69cc95c84b5eb8e3fc6cd77726e409475415223c298647b61ffa33d849dd7 SHA512 56884897b6a2b890920c689412e92489e33979f1c7f55c0d1b82fb0256ca85a32c383f4924cad524e10f95bcc75bb16680ff05460082478491800e5ede71591e WHIRLPOOL b24450c5bb4df0d882463e2d11ea2813c04cd7f8136296bc8f9f0787d7d18ccbcd869358060cbcf4bf2f2a09f6698707410e6e731d913ff94705b3b888229e13
diff --git a/dev-ruby/rails-dom-testing/metadata.xml b/dev-ruby/rails-dom-testing/metadata.xml
new file mode 100644
index 00000000000..c26fcb42a34
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">kaspth/rails-dom-testing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.5.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.5.ebuild
new file mode 100644
index 00000000000..9ed4ace5143
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/nokogiri-1.6.0
+ >=dev-ruby/rails-deprecated_sanitizer-1.0.1"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.6.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.6.ebuild
new file mode 100644
index 00000000000..9ed4ace5143
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/nokogiri-1.6.0
+ >=dev-ruby/rails-deprecated_sanitizer-1.0.1"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}