summaryrefslogtreecommitdiff
path: root/dev-ruby/rails_autolink
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rails_autolink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rails_autolink')
-rw-r--r--dev-ruby/rails_autolink/Manifest1
-rw-r--r--dev-ruby/rails_autolink/metadata.xml8
-rw-r--r--dev-ruby/rails_autolink/rails_autolink-1.1.6.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rails_autolink/Manifest b/dev-ruby/rails_autolink/Manifest
new file mode 100644
index 00000000000..208f0bccda8
--- /dev/null
+++ b/dev-ruby/rails_autolink/Manifest
@@ -0,0 +1 @@
+DIST rails_autolink-1.1.6.gem 13312 SHA256 384c17bee71ca5dc44f49401762f91abb6bc356dd564f380713fc974d2c25671 SHA512 5a9b5c2449a0a69488dbf1de3a87b987b450cfd34b420489a38801d5fcca91a2ac1c6b6b43f2f5699534a9f583a3367452d7e99da3f18619ecc23172949a8b4e WHIRLPOOL 82f51c91595f912908c53a5716a49efc7a686e024a926d29d5427182b6386b96f9294157aa0ca9722ba9f7710bc247cc8dbb9fe23794135db5a955ee705725da
diff --git a/dev-ruby/rails_autolink/metadata.xml b/dev-ruby/rails_autolink/metadata.xml
new file mode 100644
index 00000000000..db78cfab98e
--- /dev/null
+++ b/dev-ruby/rails_autolink/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tenderlove/rails_autolink</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rails_autolink/rails_autolink-1.1.6.ebuild b/dev-ruby/rails_autolink/rails_autolink-1.1.6.ebuild
new file mode 100644
index 00000000000..128cc188381
--- /dev/null
+++ b/dev-ruby/rails_autolink/rails_autolink-1.1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is an extraction of the auto_link method from rails"
+HOMEPAGE="http://github.com/tenderlove/rails_autolink"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend ">=dev-ruby/rails-3.1"