summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-readline
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rb-readline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rb-readline')
-rw-r--r--dev-ruby/rb-readline/Manifest3
-rw-r--r--dev-ruby/rb-readline/metadata.xml11
-rw-r--r--dev-ruby/rb-readline/rb-readline-0.5.1.ebuild25
-rw-r--r--dev-ruby/rb-readline/rb-readline-0.5.2.ebuild25
-rw-r--r--dev-ruby/rb-readline/rb-readline-0.5.3.ebuild25
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-ruby/rb-readline/Manifest b/dev-ruby/rb-readline/Manifest
new file mode 100644
index 00000000000..598ec581719
--- /dev/null
+++ b/dev-ruby/rb-readline/Manifest
@@ -0,0 +1,3 @@
+DIST rb-readline-0.5.1.gem 96256 SHA256 da4eb0aa71c4225e01f5b51e11a640b462fa325d85451428ce34190d04622aad SHA512 e74c7b6bff49ad5949f596cf8ce7db9204e3e7586093bd843d5e567598f78ddb46fd9aeaebe851e7086a15e2a8eb6c722ca6f7a3802accc7bbacc90a42b79236 WHIRLPOOL 664dc195eac86fe46d62aadeb458644d9a66225c8b8a64e57c30d72765bd18b3092a67795829ccaea624842e647d99a4ef9065dc51b809002d458a53d0f59ecd
+DIST rb-readline-0.5.2.gem 96256 SHA256 2b2417d94b75bb868d112cbdaa89986d01ba5af37587bfbbac3ff4d852c034f3 SHA512 7b4d314484fe8a66aecae4f997876189c57f05afdd6d1053cabfb6f41ebd38d347db24b648bfe468a5ad58c7a12ab59791553f3091ce17d9c89694690c7e7ff0 WHIRLPOOL d148b3cb227f96a206197a2ef4a36f3924926cbd9daa71441bb92094cb07a0918d9e464f0409ae52a512eae79fff5e6dd5a56c78302abfb86f549b4d3104c648
+DIST rb-readline-0.5.3.gem 96256 SHA256 5983bcff4d93090b313fcdfb68bb0ab160aef893b398022d06b08be84b96fff6 SHA512 8fa020fdedd0184c7d220d347a035e202a142a347776d91dfe87b1a0a53d43c460ea70f2cabd2b6e5e643dd9ac52f1d70dc496bb54b7b2e78e7da85a82c0400e WHIRLPOOL 32751ef4a150ce069514219538dfc07352428894e72f73de477d48d657900d0f4aa156d3d41c18acf0b757255b7e32853f0aab5bcf1ce10d9391e8517d857d17
diff --git a/dev-ruby/rb-readline/metadata.xml b/dev-ruby/rb-readline/metadata.xml
new file mode 100644
index 00000000000..67d8219afee
--- /dev/null
+++ b/dev-ruby/rb-readline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/rb-readline/rb-readline-0.5.1.ebuild b/dev-ruby/rb-readline/rb-readline-0.5.1.ebuild
new file mode 100644
index 00000000000..f70e65dc76b
--- /dev/null
+++ b/dev-ruby/rb-readline/rb-readline-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby implementation of the GNU readline C library"
+HOMEPAGE="http://rubygems.org/gems/rb-readline"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ >=dev-ruby/minitest-5.2"
+
+all_ruby_prepare() {
+ # Skip a test that fails when run in the ebuild environment.
+ sed -i -e '/test_readline_with_default_parameters_does_not_error/,/end/ s:^:#:' test/test_readline.rb || die
+}
diff --git a/dev-ruby/rb-readline/rb-readline-0.5.2.ebuild b/dev-ruby/rb-readline/rb-readline-0.5.2.ebuild
new file mode 100644
index 00000000000..8466f0ed46d
--- /dev/null
+++ b/dev-ruby/rb-readline/rb-readline-0.5.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby implementation of the GNU readline C library"
+HOMEPAGE="http://rubygems.org/gems/rb-readline"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ >=dev-ruby/minitest-5.2"
+
+all_ruby_prepare() {
+ # Skip a test that fails when run in the ebuild environment.
+ sed -i -e '/test_readline_with_default_parameters_does_not_error/,/end/ s:^:#:' test/test_readline.rb || die
+}
diff --git a/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild b/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild
new file mode 100644
index 00000000000..8466f0ed46d
--- /dev/null
+++ b/dev-ruby/rb-readline/rb-readline-0.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby implementation of the GNU readline C library"
+HOMEPAGE="http://rubygems.org/gems/rb-readline"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ >=dev-ruby/minitest-5.2"
+
+all_ruby_prepare() {
+ # Skip a test that fails when run in the ebuild environment.
+ sed -i -e '/test_readline_with_default_parameters_does_not_error/,/end/ s:^:#:' test/test_readline.rb || die
+}