summaryrefslogtreecommitdiff
path: root/dev-ruby/rest-client/rest-client-2.0.2.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-26 06:51:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-26 06:51:16 +0200
commit8a5adebcc860819ecf6a9b3bd5d09a5637f2fcef (patch)
treeda18275cb3e7daf748f3691a95172967ec6ab28f /dev-ruby/rest-client/rest-client-2.0.2.ebuild
parent3a5657007682b70229b2429f0458e61c7e5b8323 (diff)
downloadgentoo-8a5adebcc860819ecf6a9b3bd5d09a5637f2fcef.tar.gz
gentoo-8a5adebcc860819ecf6a9b3bd5d09a5637f2fcef.tar.xz
dev-ruby/rest-client: add 2.0.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/rest-client/rest-client-2.0.2.ebuild')
-rw-r--r--dev-ruby/rest-client/rest-client-2.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rest-client/rest-client-2.0.2.ebuild b/dev-ruby/rest-client/rest-client-2.0.2.ebuild
new file mode 100644
index 00000000000..ebc8e6a93c6
--- /dev/null
+++ b/dev-ruby/rest-client/rest-client-2.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="history.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Simple HTTP and REST client for Ruby"
+HOMEPAGE="https://github.com/archiloque/rest-client"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/webmock:2 )"
+
+ruby_add_rdepend "
+ >=dev-ruby/http-cookie-1.0.2:0
+ >=dev-ruby/mime-types-1.16:* <dev-ruby/mime-types-4:*
+ >=dev-ruby/netrc-0.8:0
+ !!<dev-ruby/rest-client-1.8.0-r3:0"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/namespace :windows/,/^end/ s:^:#:' -i Rakefile || die
+
+ # Remove spec that requires network access.
+ rm spec/integration/request_spec.rb || die
+}