summaryrefslogtreecommitdiff
path: root/dev-ruby/right_http_connection
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/right_http_connection
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/right_http_connection')
-rw-r--r--dev-ruby/right_http_connection/Manifest2
-rw-r--r--dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch10
-rw-r--r--dev-ruby/right_http_connection/metadata.xml8
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.3.0-r1.ebuild42
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild42
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.5.0.ebuild51
6 files changed, 155 insertions, 0 deletions
diff --git a/dev-ruby/right_http_connection/Manifest b/dev-ruby/right_http_connection/Manifest
new file mode 100644
index 00000000000..4a5a36cf198
--- /dev/null
+++ b/dev-ruby/right_http_connection/Manifest
@@ -0,0 +1,2 @@
+DIST right_http_connection-1.3.0.tgz 113955 SHA256 d84c9de72761f532aeb803a2e9ba854f3ddadfb4f47e57d05c671f1dc41362f0 SHA512 f119c23d815514ad1724581d150271128fdb603962961bcb637c3d16d157c9ecd588e1b1dfb51adb58108f72164dbefa2f59a408e5800654aa79cb30ebb868c4 WHIRLPOOL d92355564bb544065cf2af8759ed51e4639354ec546edeb38e71b9df290f4a3aefbdd9f05151b874a566192d02d2806425848de8b7b5ef299fc0101706829d0e
+DIST right_http_connection-1.5.0.tgz 120451 SHA256 e644a0f7464753d6e3d6c52e0364a5fef6ea4cd6d166272c3928a1492478fc72 SHA512 7db0e85ba8140343ef06bbfce2d9ee5f6ce6823fdcfee71875c74a609e77de043a0e5d6fced18ee2bd111ea6a8a592d3855e1547dc2bfec0e963e446c366aef7 WHIRLPOOL 302e1c61d4316293b1ceb6f9c9599220a355df3eb542ede13980b1af854f136bde34a6dcf35b5aaf34aef80366a5f0e474e0f5df8721d53b05f9fcf44d6007df
diff --git a/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch b/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch
new file mode 100644
index 00000000000..3133194fefb
--- /dev/null
+++ b/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch
@@ -0,0 +1,10 @@
+--- lib/right_http_connection.rb.old 2010-01-28 00:35:07.000000000 +0100
++++ lib/right_http_connection.rb 2010-02-11 20:20:28.872034048 +0100
+@@ -299,6 +299,7 @@
+ true
+ }
+ @http.use_ssl = true
++ @http.verify_mode = OpenSSL::SSL::VERIFY_NONE # Looks like Ruby 1.9 defaults to VERIFY_PEER which doesn't work well
+ ca_file = get_param(:ca_file)
+ if ca_file
+ @http.verify_mode = OpenSSL::SSL::VERIFY_PEER
diff --git a/dev-ruby/right_http_connection/metadata.xml b/dev-ruby/right_http_connection/metadata.xml
new file mode 100644
index 00000000000..59dcc28effb
--- /dev/null
+++ b/dev-ruby/right_http_connection/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rightscale/right_http_connection</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.3.0-r1.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.3.0-r1.ebuild
new file mode 100644
index 00000000000..06af3dbb265
--- /dev/null
+++ b/dev-ruby/right_http_connection/right_http_connection-1.3.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RightScale's robust HTTP/S connection module"
+HOMEPAGE="http://rightscale.rubyforge.org/"
+SRC_URI="https://github.com/rightscale/right_http_connection/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="rightscale-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test"
+#USE_RUBY="ruby19" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+ sed -i -e '/bundler/ s:^:#:' features/support/env.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19)
+ ;;
+ *)
+ ${RUBY} -S cucumber features || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
new file mode 100644
index 00000000000..e6c3f2d3668
--- /dev/null
+++ b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RightScale's robust HTTP/S connection module"
+HOMEPAGE="http://rightscale.rubyforge.org/"
+SRC_URI="https://github.com/rightscale/right_http_connection/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="rightscale-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test"
+#USE_RUBY="ruby19" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+ sed -i -e '/bundler/ s:^:#:' features/support/env.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19)
+ ;;
+ *)
+ ${RUBY} -S cucumber features || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.5.0.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.5.0.ebuild
new file mode 100644
index 00000000000..f8dbeb01c54
--- /dev/null
+++ b/dev-ruby/right_http_connection/right_http_connection-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RightScale's robust HTTP/S connection module"
+HOMEPAGE="https://github.com/rightscale/right_http_connection"
+SRC_URI="https://github.com/rightscale/right_http_connection/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+USE_RUBY="${USE_RUBY/ruby22/}" ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec:2
+ dev-ruby/trollop:0
+ dev-ruby/flexmock
+)"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 'arequire "rspec"' features/support/env.rb || die
+
+ # Avoid features that require manual input (PEM pass phrase) or have
+ # certificate issues due to unknown CA.
+ rm -f features/{proxy_ssl,ssl}.feature || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby22)
+ einfo "cucumber is not yet available for ruby22"
+ ;;
+ *)
+ ${RUBY} -S cucumber --format progress features || die
+ ;;
+ esac
+}