summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-dict
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-dict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-dict')
-rw-r--r--dev-ruby/ruby-dict/Manifest1
-rw-r--r--dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch20
-rw-r--r--dev-ruby/ruby-dict/metadata.xml5
-rw-r--r--dev-ruby/ruby-dict/ruby-dict-0.9.4-r3.ebuild41
-rw-r--r--dev-ruby/ruby-dict/ruby-dict-0.9.4-r4.ebuild35
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/ruby-dict/Manifest b/dev-ruby/ruby-dict/Manifest
new file mode 100644
index 00000000000..26513680562
--- /dev/null
+++ b/dev-ruby/ruby-dict/Manifest
@@ -0,0 +1 @@
+DIST ruby-dict-0.9.4.tar.gz 50487 SHA256 d44c960869e232a23b10516761a9b6ad56427ec418033b003a65082c2af045b2 SHA512 54ce421c1bf49d0d52fc2549409887e05ebac5d3d1d50fc1b3a2ef55eb1242af509e3fb2ee046ee3389b088ca951a9903e9ea3ed3ca3dcfb0d521acd0eb54c59 WHIRLPOOL c0ba38b9819bfaf0a84d3ed39c857d2a9019e7f437e81add86e8b866a81b7ec2556e04c48359ed0c7eb7007136912f86585c4def97b615fb35b59d4fdc3dc182
diff --git a/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch b/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch
new file mode 100644
index 00000000000..5ed897773fa
--- /dev/null
+++ b/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch
@@ -0,0 +1,20 @@
+--- lib/dict.rb.orig 2013-10-27 19:15:03.957167192 +0100
++++ lib/dict.rb 2013-10-27 19:16:15.191165936 +0100
+@@ -153,7 +153,7 @@
+
+
+ require 'socket'
+-require 'md5'
++require 'digest/md5'
+
+
+ # lines that start with .. need to be reduced to .
+@@ -434,7 +434,7 @@
+ # AUTHorise user
+ #
+ def auth(user, secret)
+- auth = MD5::new(@msgid + secret).hexdigest
++ auth = Digest::MD5.new.hexdigest(@msgid + secret)
+ exec_cmd('AUTH %s %s' % [ user, auth ])
+ end
+
diff --git a/dev-ruby/ruby-dict/metadata.xml b/dev-ruby/ruby-dict/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/ruby-dict/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-dict/ruby-dict-0.9.4-r3.ebuild b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r3.ebuild
new file mode 100644
index 00000000000..058d4549681
--- /dev/null
+++ b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="RFC 2229 client in Ruby"
+HOMEPAGE="http://www.caliban.org/ruby/ruby-dict.shtml"
+SRC_URI="http://www.caliban.org/files/ruby/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-ruby19.patch" )
+
+each_ruby_test() {
+ ewarn "Tests will use network connection"
+
+ ${RUBY} -Ilib ./rdict test || die
+}
+
+each_ruby_install() {
+ doruby lib/dict.rb || die "doruby failed"
+}
+
+all_ruby_install() {
+ dobin rdict
+
+ dodoc README Changelog TODO doc/rfc2229.txt
+ dohtml doc/dict.html doc/rdict.html
+
+ # This would probably need a 3rb section..
+ # doman doc/dict.3
+ doman doc/rdict.1
+}
diff --git a/dev-ruby/ruby-dict/ruby-dict-0.9.4-r4.ebuild b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r4.ebuild
new file mode 100644
index 00000000000..eae77372b9c
--- /dev/null
+++ b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="RFC 2229 client in Ruby"
+HOMEPAGE="http://www.caliban.org/ruby/ruby-dict.shtml"
+SRC_URI="http://www.caliban.org/files/ruby/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-ruby19.patch" )
+
+each_ruby_install() {
+ doruby lib/dict.rb || die "doruby failed"
+}
+
+all_ruby_install() {
+ dobin rdict
+
+ dodoc README Changelog TODO doc/rfc2229.txt
+ dohtml doc/dict.html doc/rdict.html
+
+ # This would probably need a 3rb section..
+ # doman doc/dict.3
+ doman doc/rdict.1
+}