summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-filemagic
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-filemagic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-filemagic')
-rw-r--r--dev-ruby/ruby-filemagic/Manifest2
-rw-r--r--dev-ruby/ruby-filemagic/metadata.xml8
-rw-r--r--dev-ruby/ruby-filemagic/ruby-filemagic-0.6.3.ebuild37
-rw-r--r--dev-ruby/ruby-filemagic/ruby-filemagic-0.7.0.ebuild37
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/ruby-filemagic/Manifest b/dev-ruby/ruby-filemagic/Manifest
new file mode 100644
index 00000000000..261b4d7c2af
--- /dev/null
+++ b/dev-ruby/ruby-filemagic/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-filemagic-0.6.3.gem 216064 SHA256 f9e89cbbeeb69ec4b3181d16cd3efc900b0f1c561b57c6e7a04423501d25d87f SHA512 9d52360805d5ef389293e75cbd205be3f93fc4e2158ff07b653e308262b5c63bd067eea58a86e1e69546e424b037ca11e66bca9feebe04fc33d435d4e49f69b8 WHIRLPOOL d6f4f27fce72f4c6eef3f6852586f37d01ad39d42332790f01d67b031c8fe8c43a39b7b2d2fae03c57ef77fafc996004c2791f9295903c1751fb05ae44ced38f
+DIST ruby-filemagic-0.7.0.gem 229376 SHA256 e28af7f49955d800c3dfd1a2335c5c1aa9f380e57eda16050250e4345ad0e460 SHA512 ba257ac7ae58e664d0a45c319c9159650a267144941fdf558f2bd7aa442133f8303637153ab1eb89611c8709303afebbab42f1c3674cca89d15f5037c9bc9d43 WHIRLPOOL 8f64cdea5c7ec028e2d9bf116700e34cda12264946ae847ae5cbd014bd0518368788c6769c49c09775f7cdb3f647a6391cfffc4af29b139be4637a34ad4296eb
diff --git a/dev-ruby/ruby-filemagic/metadata.xml b/dev-ruby/ruby-filemagic/metadata.xml
new file mode 100644
index 00000000000..9bd44e8fb23
--- /dev/null
+++ b/dev-ruby/ruby-filemagic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<upstream>
+<remote-id type="github">blackwinter/ruby-filemagic</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-filemagic/ruby-filemagic-0.6.3.ebuild b/dev-ruby/ruby-filemagic/ruby-filemagic-0.6.3.ebuild
new file mode 100644
index 00000000000..5106e776844
--- /dev/null
+++ b/dev-ruby/ruby-filemagic/ruby-filemagic-0.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby binding to libmagic"
+HOMEPAGE="http://ruby-filemagic.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND} sys-apps/file"
+RDEPEND="${RDEPEND} sys-apps/file"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/filemagic extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/filemagic
+ mv ext/filemagic/ruby_filemagic$(get_modname) lib/filemagic/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest -I../lib filemagic_test.rb || die
+}
diff --git a/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.0.ebuild b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.0.ebuild
new file mode 100644
index 00000000000..9424dcba04f
--- /dev/null
+++ b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby binding to libmagic"
+HOMEPAGE="https://github.com/blackwinter/ruby-filemagic"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND} sys-apps/file"
+RDEPEND="${RDEPEND} sys-apps/file"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/filemagic extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/filemagic
+ mv ext/filemagic/ruby_filemagic$(get_modname) lib/filemagic/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest -I../lib filemagic_test.rb || die
+}