summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2017-03-16 10:05:29 +0900
committerNaohiro Aota <naota@gentoo.org>2017-03-16 10:14:07 +0900
commitc56c22edaca843cc3ad3b13ba4312860d25433f6 (patch)
tree8f242fb1f6b86edb07802b3c256b449ce2181181 /dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild
parente933e66dfbd0d99f714c68e66cbc6b0bc8f3e30b (diff)
downloadgentoo-c56c22edaca843cc3ad3b13ba4312860d25433f6.tar.gz
gentoo-c56c22edaca843cc3ad3b13ba4312860d25433f6.tar.xz
dev-ruby/ruby-gnome2: bump to 3.1.1 packages
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild
new file mode 100644
index 00000000000..37494e985ce
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-3.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+ruby_add_bdepend "dev-ruby/pkg-config
+ test? ( >=dev-ruby/test-unit-2 )"
+
+all_ruby_prepare() {
+ # Skip spawn tests since our sandbox also provides items in the environment and this makes the test fragile.
+ rm -f test/test_spawn.rb || die
+
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/glib2/Makefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}