summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-mp3info
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-mp3info
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-mp3info')
-rw-r--r--dev-ruby/ruby-mp3info/Manifest2
-rw-r--r--dev-ruby/ruby-mp3info/metadata.xml8
-rw-r--r--dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild32
-rw-r--r--dev-ruby/ruby-mp3info/ruby-mp3info-0.8.7.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/ruby-mp3info/Manifest b/dev-ruby/ruby-mp3info/Manifest
new file mode 100644
index 00000000000..ef24df1a878
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-mp3info-0.8.6-git.tgz 88463 SHA256 1b52aff957da105641fcb1713a4afdb031aa6dcc064b1f81f36b744e00754f1f SHA512 3b536850d18a6ab0da9a9d096c79b78e6ec2b8fec78a551dc1b44a94b97a77a37fbb8db7d3fc6fa41c1b0732d949de624b89bf28119752c0486f703a1d0873ea WHIRLPOOL 8edbd44d271f77fa2eee2cb4cbba1b30af626e4a496dc55b91b3ac5470e237b651c715fa56ace937ab985ea1640823f11ccd0e30afc8de7fd0c5a8e344658e9e
+DIST ruby-mp3info-0.8.7-git.tgz 89119 SHA256 f7e5df39b44748f7ceb2d246ecbafbc66b35144d0e7b789db3e04993d5bfea8b SHA512 4b1cfdd4c94d98a78fddeb67639265c5d1aa333fae847ac42663bb93d2e8380d46b6e87482c117001cc14ad9b1f6f2cc2dbb865c5fd12c4ec22e6ca26565685a WHIRLPOOL 8345b8d5e6ad5254a5313dfbf310953c8904e38586cea4d029c73ad4c09700fe25064d807528ae83d45da32511b8c3a254d721b3350f340984958ba9ec391cd5
diff --git a/dev-ruby/ruby-mp3info/metadata.xml b/dev-ruby/ruby-mp3info/metadata.xml
new file mode 100644
index 00000000000..c9241406f2e
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">moumar/ruby-mp3info</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild
new file mode 100644
index 00000000000..eb2623a01f6
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for access to mp3 files (internal infos and tags)"
+HOMEPAGE="http://rubyforge.org/projects/ruby-mp3info/"
+SRC_URI="https://github.com/moumar/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND+=" test? ( media-sound/id3v2 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Use a newer test-unit than is shipped with ruby19
+ sed -i -e '6igem "test-unit"' test/test_ruby-mp3info.rb || die
+}
diff --git a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.7.ebuild b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.7.ebuild
new file mode 100644
index 00000000000..eb2623a01f6
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for access to mp3 files (internal infos and tags)"
+HOMEPAGE="http://rubyforge.org/projects/ruby-mp3info/"
+SRC_URI="https://github.com/moumar/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND+=" test? ( media-sound/id3v2 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Use a newer test-unit than is shipped with ruby19
+ sed -i -e '6igem "test-unit"' test/test_ruby-mp3info.rb || die
+}