summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-odbc
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-07 07:11:00 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-07 07:11:00 +0200
commit3f0ec1754fb713ca1b176d6cf487fdaf73fc02ca (patch)
treeff017b37a8febe22cf77fc02f8ac924e9e5ec9e9 /dev-ruby/ruby-odbc
parent7a3a8c77f94466e34b8598964b0e75acc98b47b4 (diff)
downloadgentoo-3f0ec1754fb713ca1b176d6cf487fdaf73fc02ca.tar.gz
gentoo-3f0ec1754fb713ca1b176d6cf487fdaf73fc02ca.tar.xz
dev-ruby/ruby-odbc: cleanup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/ruby-odbc')
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99997.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99997.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99997.ebuild
deleted file mode 100644
index a812c614173..00000000000
--- a/dev-ruby/ruby-odbc/ruby-odbc-0.99997.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
-
-inherit ruby-fakegem
-
-DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
-HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
-SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="${DEPEND} >=dev-db/unixODBC-2.0.6"
-RDEPEND="${RDEPEND} >=dev-db/unixODBC-2.0.6"
-
-# tests require to have an ODBC service enabled, so we can't run them
-# for now :(
-RESTRICT=test
-
-all_ruby_prepare() {
- # Make sure that it doesn't try to use the absolute-local path for
- # the extension as we'd be unable to run it properly otherwise.
- sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
-
- # Since lib should not get installed avoid it entirely…
- mv lib contrib || die
-}
-
-each_ruby_configure() {
- for dir in ext ext/utf8; do
- ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
- done
-}
-
-each_ruby_compile() {
- for dir in ext ext/utf8; do
- emake V=1 -C${dir} || die "emake (${dir}) failed"
- done
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- ruby_fakegem_newins ext/odbc.so lib/odbc.so
- ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
-}
-
-all_ruby_install() {
- all_fakegem_install
- dohtml doc/*.html || die
-}