summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-17 14:14:27 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-18 07:09:20 +0100
commit50f63e57d6f1ad9e8718c0099300d110f5cd3daa (patch)
tree281ce30c5d47e9637352c7b0accc45791b2ff9de /dev-ruby/ruby-prof
parent5b1bffd42b27486de7633886c0ad12c877cae03d (diff)
downloadgentoo-50f63e57d6f1ad9e8718c0099300d110f5cd3daa.tar.gz
gentoo-50f63e57d6f1ad9e8718c0099300d110f5cd3daa.tar.xz
dev-ruby/ruby-prof: install extension where it can be found
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild67
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild (renamed from dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild)6
3 files changed, 1 insertions, 73 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index f7b164e5924..c0063ba4940 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,2 +1 @@
-DIST ruby-prof-0.15.1.tgz 207847 SHA256 c0305095274bbead21b323812acc63c0051b387dd92bd23f8edc28b03b00f7af SHA512 3b94e07c76aa51381e964095777dd8c45288319f6b0f56b886a95fc220a95da0db5da311624635c64725298298c66cbac6dc6fcbc293be2aef462b003a78019b WHIRLPOOL d75f53845c5a91b624fa1da67c507f89537650c3db25a0b21e0a0dfb4e3ad91bc82578c861b3ba60b6fa24689f7eab0b08c77aed0680b0e7c304aad1ea288854
DIST ruby-prof-0.15.8.tgz 81627 SHA256 9e210052402003e41f041605291decdc5e794ae61894ab52651ffb70aeb17504 SHA512 d53fdd936dd4d7e8071a3d85877e3a82a307c62e20488ca8604e9041e4bf830568d8d1e6bde7ad463f15b07748a29669515e1a0b199e2df2562bd10a07bb935a WHIRLPOOL ce42ea37ad8b3f96c2d2a4afca8bec6cec603654a651e30cf728d24ea34c953f9a4999ee5707601c0f728231654fad9f9c5febf32dfa579bd58b5828c6957b94
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
deleted file mode 100644
index ab4ffa752c8..00000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# jruby → not compatible, since it uses an extension, but there is a bug
-# open for it: https://github.com/rdp/ruby-prof/issues/36
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' test/test_helper.rb || die
-
- # Fix a timing-dependant spec since its thresholds for success are
- # too tight.
- sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-
- # Create directory required for the test suite to pass
- mkdir tmp || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples ; do
- docinto "$dir"
- dodoc -r "$dir"/*
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild
index 5f412657abd..d319c368aaf 100644
--- a/dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild
+++ b/dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild
@@ -4,9 +4,6 @@
EAPI=5
-# jruby → not compatible, since it uses an extension, but there is a bug
-# open for it: https://github.com/rdp/ruby-prof/issues/36
-
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
@@ -53,8 +50,7 @@ each_ruby_configure() {
each_ruby_compile() {
emake V=1 -Cext/ruby_prof || die "build failed"
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+ cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
}
all_ruby_install() {