summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-prof
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest2
-rw-r--r--dev-ruby/ruby-prof/metadata.xml8
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild67
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild67
4 files changed, 144 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
new file mode 100644
index 00000000000..f7b164e5924
--- /dev/null
+++ b/dev-ruby/ruby-prof/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-prof-0.15.1.tgz 207847 SHA256 c0305095274bbead21b323812acc63c0051b387dd92bd23f8edc28b03b00f7af SHA512 3b94e07c76aa51381e964095777dd8c45288319f6b0f56b886a95fc220a95da0db5da311624635c64725298298c66cbac6dc6fcbc293be2aef462b003a78019b WHIRLPOOL d75f53845c5a91b624fa1da67c507f89537650c3db25a0b21e0a0dfb4e3ad91bc82578c861b3ba60b6fa24689f7eab0b08c77aed0680b0e7c304aad1ea288854
+DIST ruby-prof-0.15.8.tgz 81627 SHA256 9e210052402003e41f041605291decdc5e794ae61894ab52651ffb70aeb17504 SHA512 d53fdd936dd4d7e8071a3d85877e3a82a307c62e20488ca8604e9041e4bf830568d8d1e6bde7ad463f15b07748a29669515e1a0b199e2df2562bd10a07bb935a WHIRLPOOL ce42ea37ad8b3f96c2d2a4afca8bec6cec603654a651e30cf728d24ea34c953f9a4999ee5707601c0f728231654fad9f9c5febf32dfa579bd58b5828c6957b94
diff --git a/dev-ruby/ruby-prof/metadata.xml b/dev-ruby/ruby-prof/metadata.xml
new file mode 100644
index 00000000000..91a53b1bd6d
--- /dev/null
+++ b/dev-ruby/ruby-prof/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-prof/ruby-prof</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
new file mode 100644
index 00000000000..ab4ffa752c8
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → not compatible, since it uses an extension, but there is a bug
+# open for it: https://github.com/rdp/ruby-prof/issues/36
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # Fix a timing-dependant spec since its thresholds for success are
+ # too tight.
+ sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild
new file mode 100644
index 00000000000..5f412657abd
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.15.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → not compatible, since it uses an extension, but there is a bug
+# open for it: https://github.com/rdp/ruby-prof/issues/36
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # Fix a timing-dependant spec since its thresholds for success are
+ # too tight.
+ sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}