summaryrefslogtreecommitdiff
path: root/dev-ruby/serialport
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/serialport
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/serialport')
-rw-r--r--dev-ruby/serialport/Manifest2
-rw-r--r--dev-ruby/serialport/metadata.xml5
-rw-r--r--dev-ruby/serialport/serialport-1.3.0.ebuild50
-rw-r--r--dev-ruby/serialport/serialport-1.3.1.ebuild49
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/serialport/Manifest b/dev-ruby/serialport/Manifest
new file mode 100644
index 00000000000..9c683a751a2
--- /dev/null
+++ b/dev-ruby/serialport/Manifest
@@ -0,0 +1,2 @@
+DIST serialport-1.3.0.gem 25088 SHA256 39bd909a3b159e70070dd24e6948bb7620fcb1fb066d26fc55aab2ae1037f21a SHA512 7555f5125a031de4467c4bf5312e31be021265398ed22d2a6089232faa904aa8de0accd092fbe5f74aeba16d8bf37529014ac148d2fdd45d0e43f11bba7ec94d WHIRLPOOL 5b730cf11263130f222d072354003a16dc83374ffbeedfed8a48f04836447b3fb331eb07d0777f3894bc6f27a9d262af7eaeeb572dc7fb880fcd0304cfcefb42
+DIST serialport-1.3.1.gem 25088 SHA256 59293f68d8d6fe8e54726a238f46143f0e5541d4232cc211f10cb627c8219747 SHA512 cdce9e13065cecf6d090d716626abb399bcc2a079be7bf1fe7755a20360218550f2f31980d62d8aae1fcc62fc62d6f7549685f865e30d2a5f40a617f5f197ed9 WHIRLPOOL 0e0521aa7feb35aa7f68201c77620605e74c5ba58b8bf95b52b0cc8ba0ca1165bbe5456e9c038459897fd2dfe68cab67a534ec85c3a25df31563b0442601445d
diff --git a/dev-ruby/serialport/metadata.xml b/dev-ruby/serialport/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/serialport/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/serialport/serialport-1.3.0.ebuild b/dev-ruby/serialport/serialport-1.3.0.ebuild
new file mode 100644
index 00000000000..ec20a679c28
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → uses native library
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native || die
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake V=1
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # don't compress it
+ insinto /usr/share/doc/${PF}/examples
+ doins test/miniterm.rb
+}
diff --git a/dev-ruby/serialport/serialport-1.3.1.ebuild b/dev-ruby/serialport/serialport-1.3.1.ebuild
new file mode 100644
index 00000000000..71881797aa5
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native || die
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake V=1
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # don't compress it
+ insinto /usr/share/doc/${PF}/examples
+ doins test/miniterm.rb
+}