summaryrefslogtreecommitdiff
path: root/dev-ruby/shotgun
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/shotgun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/shotgun')
-rw-r--r--dev-ruby/shotgun/Manifest2
-rw-r--r--dev-ruby/shotgun/metadata.xml8
-rw-r--r--dev-ruby/shotgun/shotgun-0.9-r1.ebuild32
-rw-r--r--dev-ruby/shotgun/shotgun-0.9.1.ebuild37
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/Manifest b/dev-ruby/shotgun/Manifest
new file mode 100644
index 00000000000..37449384e71
--- /dev/null
+++ b/dev-ruby/shotgun/Manifest
@@ -0,0 +1,2 @@
+DIST shotgun-0.9.1.gem 16384 SHA256 e426e4557ddd3a9a7015b06934aa30dc9038faf04bff5c5e9cd93a599c73ae8d SHA512 eae31007c4a27a660d4bc8bd0b87b4281c1c50a6c9c4675e492b8914a412dc5a2f21998f8b9105b0ada64600c1322d0bd936c4fd4b032dc57aaf1612827208f7 WHIRLPOOL 1bdce842ef3eb606a860052ea95315eb57e3237bd44d4aa76c5e360018377135ae69364e7550041f4492924bc7328b71b7be0203f566a02d004859396e6f68bb
+DIST shotgun-0.9.gem 14336 SHA256 5518285ff9494a36841345985857fb848aeab9981bc2c0d964f08c10315045a5 SHA512 55bc886df596606db9324da4441e3b9585355dedeca0e135b50c52a46640efa83dd378b5e86b35d631b51c4ad8839313809d88932282447b30a23a9bf2827196 WHIRLPOOL 15cecfacdb7b2d6fbdb5982915e37f4eeb48fec5b95f05e84464b23f31623658a5da85f2142f671d5312f47e0d67a95e536db2e6ef3ead29b0d005797adf3274
diff --git a/dev-ruby/shotgun/metadata.xml b/dev-ruby/shotgun/metadata.xml
new file mode 100644
index 00000000000..99c5701378f
--- /dev/null
+++ b/dev-ruby/shotgun/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rtomayko/shotgun</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/shotgun/shotgun-0.9-r1.ebuild b/dev-ruby/shotgun/shotgun-0.9-r1.ebuild
new file mode 100644
index 00000000000..3398cdb0952
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="http://rtomayko.github.com/shotgun/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}
diff --git a/dev-ruby/shotgun/shotgun-0.9.1.ebuild b/dev-ruby/shotgun/shotgun-0.9.1.ebuild
new file mode 100644
index 00000000000..4d35d7fdea4
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="https://github.com/rtomayko/shotgun"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_shotgun_static.rb || die
+ ${RUBY} -Ilib test/test_shotgun_loader.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}