summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda-context
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/shoulda-context
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/Manifest2
-rw-r--r--dev-ruby/shoulda-context/metadata.xml5
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild36
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.2.1.ebuild37
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
new file mode 100644
index 00000000000..059ef2dd307
--- /dev/null
+++ b/dev-ruby/shoulda-context/Manifest
@@ -0,0 +1,2 @@
+DIST shoulda-context-1.1.6.gem 21504 SHA256 6fef28c38b63b39ae761c6f73dd1c11a6184dd5f36e2080cc3e6bdabf6845ed7 SHA512 71c6a567c807f8eda0b7b619f092326a928bb9df181ca18424f2fbbef8e7fdf8bac5990e22f68d936e7bebcab569d9c32ede5264108e914cc84e2ce40908572f WHIRLPOOL 6194f644a6d0da7cefe643c46c05a4399e21f27df72a45a19500c8128add12be7d156cd1b92a52be26d795e77d2ff1b301db0d891817911b2373fdf6039fc234
+DIST shoulda-context-1.2.1.gem 24064 SHA256 a52c1ce8aeb868af7a1f98d63f748bfdea353f98bce35181ed2bffa266149b1b SHA512 eda6f82c101d0abdf517cabd9663a6a45d9e3d1ef19bdc51d4de35a45e18de15b1aee02a7a557460a3a9b1eafa61cd892240563b6f239b94339e9869c6e63ef3 WHIRLPOOL 9a5fa8ab2e8f1511512ea82ca7d4883157174f10c2b40a76f8020839cfa946964249acd5540b8582f269952574a32866d03a463520176ddf9e1671668b1999af
diff --git a/dev-ruby/shoulda-context/metadata.xml b/dev-ruby/shoulda-context/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/shoulda-context/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
new file mode 100644
index 00000000000..0b6ba5c30db
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+each_ruby_test() {
+ ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.2.1.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.2.1.ebuild
new file mode 100644
index 00000000000..c72750e580d
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}