summaryrefslogtreecommitdiff
path: root/dev-ruby/sqlite3
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/sqlite3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/sqlite3')
-rw-r--r--dev-ruby/sqlite3/Manifest1
-rw-r--r--dev-ruby/sqlite3/metadata.xml5
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.10-r1.ebuild82
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.10.ebuild82
4 files changed, 170 insertions, 0 deletions
diff --git a/dev-ruby/sqlite3/Manifest b/dev-ruby/sqlite3/Manifest
new file mode 100644
index 00000000000..658d3b221a4
--- /dev/null
+++ b/dev-ruby/sqlite3/Manifest
@@ -0,0 +1 @@
+DIST sqlite3-1.3.10.gem 60416 SHA256 70d815be84bd9630a0b68b236fd2811eef4297a8e4b53e3df89dd39f2d39efe3 SHA512 0a35896a4b9ce4f1e0f29ef9385f13b418b089d9bad467290e21eb12a4d09ce755231f5844c5009013ac9c73a27f7050ce899660d93d6ecc9e919f048a073cfe WHIRLPOOL 95f5f6d2944012cd4778f5d29e63ae43208e247ff5a9d184409dec4756beb14b90878c5ae6b337bf3f3d1fb9049de0cf65625a8544a429c735d5d9b66f90cd1d
diff --git a/dev-ruby/sqlite3/metadata.xml b/dev-ruby/sqlite3/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/sqlite3/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.10-r1.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.10-r1.ebuild
new file mode 100644
index 00000000000..0fb21f9d2fd
--- /dev/null
+++ b/dev-ruby/sqlite3/sqlite3-1.3.10-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="faq"
+RUBY_FAKEGEM_DOCDIR="doc faq"
+RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An extension library to access a SQLite database from Ruby"
+HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND+=" =dev-db/sqlite-3*"
+DEPEND+=" =dev-db/sqlite-3*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/hoe
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # We remove the vendor_sqlite3 rake task because it's used to
+ # bundle SQlite3 which we definitely don't want.
+ rm tasks/vendor_sqlite3.rake || die
+
+ # Remove license line from hoe to avoid depending on a newer
+ # version.
+ sed -i -e '/license/d' tasks/gem.rake || die
+
+ sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/sqlite3 extconf.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "${P} Dcoumentation" -o doc --main README.rdoc lib *.rdoc ext/*/*.c || die
+}
+
+each_ruby_compile() {
+ # TODO: not sure what happens with jruby
+
+ emake -Cext/sqlite3 V=1
+ mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # sqlite3 was called sqlite3-ruby before, so add a spec file that
+ # simply loads sqlite3 to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # sqlite3` was already part of sqlite3-ruby requirements.
+ cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
+# generated by ebuild
+# $Id$
+Gem::Specification.new do |s|
+ s.name = "sqlite3-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load sqlite3"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=sqlite3-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild
new file mode 100644
index 00000000000..27c258d2ddf
--- /dev/null
+++ b/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="faq"
+RUBY_FAKEGEM_DOCDIR="doc faq"
+RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An extension library to access a SQLite database from Ruby"
+HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
+LICENSE="BSD"
+
+KEYWORDS="amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND+=" =dev-db/sqlite-3*"
+DEPEND+=" =dev-db/sqlite-3*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/hoe
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # We remove the vendor_sqlite3 rake task because it's used to
+ # bundle SQlite3 which we definitely don't want.
+ rm tasks/vendor_sqlite3.rake || die
+
+ # Remove license line from hoe to avoid depending on a newer
+ # version.
+ sed -i -e '/license/d' tasks/gem.rake || die
+
+ sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/sqlite3 extconf.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "${P} Dcoumentation" -o doc --main README.rdoc lib *.rdoc ext/*/*.c || die
+}
+
+each_ruby_compile() {
+ # TODO: not sure what happens with jruby
+
+ emake -Cext/sqlite3 V=1
+ mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # sqlite3 was called sqlite3-ruby before, so add a spec file that
+ # simply loads sqlite3 to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # sqlite3` was already part of sqlite3-ruby requirements.
+ cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
+# generated by ebuild
+# $Id$
+Gem::Specification.new do |s|
+ s.name = "sqlite3-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load sqlite3"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=sqlite3-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}