summaryrefslogtreecommitdiff
path: root/dev-ruby/sshkit
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/sshkit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest3
-rw-r--r--dev-ruby/sshkit/metadata.xml8
-rw-r--r--dev-ruby/sshkit/sshkit-1.5.1.ebuild35
-rw-r--r--dev-ruby/sshkit/sshkit-1.6.1.ebuild35
-rw-r--r--dev-ruby/sshkit/sshkit-1.7.1.ebuild35
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
new file mode 100644
index 00000000000..71893b34848
--- /dev/null
+++ b/dev-ruby/sshkit/Manifest
@@ -0,0 +1,3 @@
+DIST sshkit-1.5.1.gem 135168 SHA256 be1510b4936ee23174a4152a6b0e382a2b8244aa0d47d4e94908b641d639cd53 SHA512 d590568216366c7171e9364a260ec92e7d1ecfb00c28f0238aaa4ef40b51d21b9121ce710e627f0161b095d2a105f660e2ccaf523cc2b48557aea0f35c2ce1fe WHIRLPOOL cd004fcbfcd83bf1fb49352e1968746b40e4733fa2c2fac25a41f3179be667c71062c8d0f181ec877c708959bbe28a0a3423c89261ea91199a3318c4c21b53e1
+DIST sshkit-1.6.1.gem 135680 SHA256 8ca67e46bb4ea50fdb0553cda77552f3e41b17a5aa919877d93875dfa22c03a7 SHA512 3e1c7c0a4a5121034fccb91cf12321741dd0c8b4a1eca251a1b5daa98b23b304ca211366b488158a1b04785e5b81d392d6365ee85da8ef9cc567355692cb0054 WHIRLPOOL 9e170935062a7c3bb730bb3227f30b05f8c05d56b1b7bcaaf75267752b2d02a7689320757ba7e094309cef134249e0f514ef314625e934fcc0bf995420046081
+DIST sshkit-1.7.1.gem 136192 SHA256 69d38907dc35e21412fc143443c569c3b6a60247164507edd730557e583c0788 SHA512 55d1ac6d4f76112b9159ae2a6bc425fa54738943ffa28b94300012c8af2d69c7b060dd00adb3789940cd29f52a384edc1cfdf9a26189e0307f2662c1b7a7e1f4 WHIRLPOOL 5b9ec3772e8f79960d5cc5328ccdac943c820e55c053c689baefa5ed99bee5e5a4bae2e18e69272cc7a74897110f94502d13bb18f5de1545a3ca394518a44b55
diff --git a/dev-ruby/sshkit/metadata.xml b/dev-ruby/sshkit/metadata.xml
new file mode 100644
index 00000000000..ee090b51366
--- /dev/null
+++ b/dev-ruby/sshkit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">capistrano/sshkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/sshkit/sshkit-1.5.1.ebuild b/dev-ruby/sshkit/sshkit-1.5.1.ebuild
new file mode 100644
index 00000000000..5f488c0add1
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="http://github.com/capistrano/sshkit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0
+ >=dev-ruby/net-scp-1.1.2
+ dev-ruby/colorize
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\)/I s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/sshkit/sshkit-1.6.1.ebuild b/dev-ruby/sshkit/sshkit-1.6.1.ebuild
new file mode 100644
index 00000000000..a3cf8bbdd2c
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="http://github.com/capistrano/sshkit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0
+ >=dev-ruby/net-scp-1.1.2
+ >=dev-ruby/colorize-0.7.0
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\)/I s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/sshkit/sshkit-1.7.1.ebuild b/dev-ruby/sshkit/sshkit-1.7.1.ebuild
new file mode 100644
index 00000000000..aa54c0c2c95
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0
+ >=dev-ruby/net-scp-1.1.2
+ >=dev-ruby/colorize-0.7.0
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\)/I s:^:#:' test/helper.rb || die
+}