summaryrefslogtreecommitdiff
path: root/dev-ruby/test-unit/test-unit-3.1.9.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-05-20 22:17:08 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-05-20 22:17:08 +0200
commit190fa488f1c556b30baf1a6be98955d7450f5420 (patch)
tree09e5555515220bb9e18b2abe823dfd59f355fb5a /dev-ruby/test-unit/test-unit-3.1.9.ebuild
parentbb532ff2c70c8a687b7c239b5901939bc21fcd87 (diff)
downloadgentoo-190fa488f1c556b30baf1a6be98955d7450f5420.tar.gz
gentoo-190fa488f1c556b30baf1a6be98955d7450f5420.tar.xz
dev-ruby/test-unit: Version bump to 3.1.9
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/test-unit/test-unit-3.1.9.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-3.1.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.1.9.ebuild b/dev-ruby/test-unit/test-unit-3.1.9.ebuild
new file mode 100644
index 00000000000..c1ac970024b
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md doc/text/news.md"
+
+inherit ruby-fakegem
+
+# Assume for now that ruby23 is not eselected yet and only
+# depend on yard for the other ruby implementations. Without this
+# assumption bootstrapping ruby23 won't be possible due to the yard
+# dependency tree.
+USE_RUBY="${USE_RUBY/ruby23/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+
+LICENSE="|| ( Ruby GPL-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}