summaryrefslogtreecommitdiff
path: root/dev-ruby/test-unit
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-17 07:16:07 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-17 07:16:07 +0100
commit16781192c06194c7b40b4fb211603f03e494f796 (patch)
treee4493644c4ad18ffc06e711ffd21810934f91eaa /dev-ruby/test-unit
parentc995e08b209b76ea62a5dd00b77f3bc1fd5fc378 (diff)
downloadgentoo-16781192c06194c7b40b4fb211603f03e494f796.tar.gz
gentoo-16781192c06194c7b40b4fb211603f03e494f796.tar.xz
dev-ruby/test-unit: cleanup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.5-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-ruby/test-unit/test-unit-2.5.5-r1.ebuild b/dev-ruby/test-unit/test-unit-2.5.5-r1.ebuild
deleted file mode 100644
index ef221ba117f..00000000000
--- a/dev-ruby/test-unit/test-unit-2.5.5-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-inherit ruby-fakegem
-
-# Assume for now that ruby20 is not eselected yet and only depend on
-# yard for the other ruby implementations. Without this assumption
-# bootstrapping ruby20 won't be possible due to the yard dependency
-# tree.
-USE_RUBY="${USE_RUBY/ruby20/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY="${USE_RUBY/ruby20/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Avoid tests with slightly different output for jruby
- sed -i -e '/test_assert_nothing_thrown/,/^ end/ s:^:#:' \
- -e '/test_assert_throw/,/^ end/ s:^:#:' test/test-assertions.rb || die
- # And fix missing testunit exposed by it
- sed -i -e "9irequire 'testunit-test-util'" test/test-assertions.rb || die
- ;;
- esac
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb testrb-2
-}