summaryrefslogtreecommitdiff
path: root/dev-ruby/totoridipjp
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-03 07:16:18 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-03 07:16:18 +0100
commit11c44d084ac9d9b8c8b5ee12a31ba36b58243d2f (patch)
tree760d32b9b3c9a022e181b1424bd1df8cfda791cb /dev-ruby/totoridipjp
parent3dff0089f34c6b005470f7f68b21edbe6fc44a35 (diff)
downloadgentoo-11c44d084ac9d9b8c8b5ee12a31ba36b58243d2f.tar.gz
gentoo-11c44d084ac9d9b8c8b5ee12a31ba36b58243d2f.tar.xz
dev-ruby/totoridipjp: many fixes
Fix USE=doc and FEATURES=test cases. Use eclass mechanism for not installing binaries. Fix metadata to point to correct package. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/totoridipjp')
-rw-r--r--dev-ruby/totoridipjp/metadata.xml2
-rw-r--r--dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild14
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-ruby/totoridipjp/metadata.xml b/dev-ruby/totoridipjp/metadata.xml
index 4b45643bc78..ddf5da98f68 100644
--- a/dev-ruby/totoridipjp/metadata.xml
+++ b/dev-ruby/totoridipjp/metadata.xml
@@ -9,6 +9,6 @@
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
- <remote-id type="rubygems">delayer-deferred</remote-id>
+ <remote-id type="rubygems">totoridipjp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild b/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild
index b7ef079b14a..fad356c4679 100644
--- a/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild
+++ b/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild
@@ -1,14 +1,20 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+
inherit ruby-fakegem
+
DESCRIPTION="A ruby binding to use totori.dip.jp Web API"
HOMEPAGE="https://rubygems.org/gems/totoridipjp"
@@ -16,7 +22,3 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-
-all_ruby_prepare() {
- rm -fvr bin/ || die
-}