summaryrefslogtreecommitdiff
path: root/dev-ruby/transaction-simple
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/transaction-simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/transaction-simple')
-rw-r--r--dev-ruby/transaction-simple/Manifest1
-rw-r--r--dev-ruby/transaction-simple/metadata.xml8
-rw-r--r--dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r1.ebuild32
-rw-r--r--dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild32
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/transaction-simple/Manifest b/dev-ruby/transaction-simple/Manifest
new file mode 100644
index 00000000000..c2a9c643449
--- /dev/null
+++ b/dev-ruby/transaction-simple/Manifest
@@ -0,0 +1 @@
+DIST transaction-simple-1.4.0.2.gem 17408 SHA256 87754b8b4ad9d2b7fe91b599f78e9122dc94837d3abd98e227bb6f82b4a8ad59 SHA512 083c2c0d8c094d052a5262e21911985a3bf91875892844fb0559546901eea21ef14b139d7af6446c7a7bfbd1adf177e2d73cba2798c823bf295a6c87981165a4 WHIRLPOOL 8e9dbf6c03fbf9fb8ddf1f0ec15ba8b479a1047c55c3b7e6bd942f83c34b80c3eae6d5a876c009e0ea76560b756442d89678fb5eb3f296abc35d4def56a84d22
diff --git a/dev-ruby/transaction-simple/metadata.xml b/dev-ruby/transaction-simple/metadata.xml
new file mode 100644
index 00000000000..37fc4905b00
--- /dev/null
+++ b/dev-ruby/transaction-simple/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">halostatue/transaction-simple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r1.ebuild b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r1.ebuild
new file mode 100644
index 00000000000..1c08c272187
--- /dev/null
+++ b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides transaction support at the object level"
+HOMEPAGE="https://github.com/halostatue/transaction-simple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}
diff --git a/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild
new file mode 100644
index 00000000000..aef1590a029
--- /dev/null
+++ b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides transaction support at the object level"
+HOMEPAGE="https://github.com/halostatue/transaction-simple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}