summaryrefslogtreecommitdiff
path: root/dev-ruby/unf_ext
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/unf_ext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/unf_ext')
-rw-r--r--dev-ruby/unf_ext/Manifest2
-rw-r--r--dev-ruby/unf_ext/metadata.xml5
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.6-r1.ebuild47
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild47
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.7.1.ebuild47
5 files changed, 148 insertions, 0 deletions
diff --git a/dev-ruby/unf_ext/Manifest b/dev-ruby/unf_ext/Manifest
new file mode 100644
index 00000000000..16ffa3ccba0
--- /dev/null
+++ b/dev-ruby/unf_ext/Manifest
@@ -0,0 +1,2 @@
+DIST unf_ext-0.0.6.gem 395264 SHA256 afcdba30a57665a4540c5d43b2833c6a3677a3296428fa70fbd7b4c8feaceb1f SHA512 ae6df02589e0ce4189127836bdc18f7cc2f1c7f7fd2647f0b8d0a80f1175ad1f682a983195527e4f0b50b685de0aaf9377b7c5e955dc49d802176b2db63fc869 WHIRLPOOL 25d54eb777e00b4c96c87079159e05a94c5507d1f165fec6803337f9f4c7f0b8069d578702f5dc2ab0ae05c89b6cbab8b28aa29fbd6d18082c903a0af6cc06df
+DIST unf_ext-0.0.7.1.gem 392192 SHA256 ab58d1a808d38872817bea89fc3f055bfc250af48d9653425e35c7c18caec253 SHA512 06239dc5870ad0f345266b12ad6ed9508ab731dfd37b450d0e1eae1ef8e8301f8ad1ef7fffbbcf69b56b0af5aa257ea279dda3a252bdf397d11949e9885db3d4 WHIRLPOOL 4d5d8c6efb46bb46b65967101389b5b7414bfa507d591e29dfb9d8c354555b9b92a997f19b68e0d4aa58143bf836849f152dafc2936b13a11cac74d7063f3d16
diff --git a/dev-ruby/unf_ext/metadata.xml b/dev-ruby/unf_ext/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/unf_ext/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.6-r1.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.6-r1.ebuild
new file mode 100644
index 00000000000..a23a6cc594a
--- /dev/null
+++ b/dev-ruby/unf_ext/unf_ext-0.0.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Unicode Normalization Form support library for CRuby"
+HOMEPAGE="http://sourceforge.jp/projects/unf/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/unf_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/unf_ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild
new file mode 100644
index 00000000000..01ef53df52f
--- /dev/null
+++ b/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Unicode Normalization Form support library for CRuby"
+HOMEPAGE="http://sourceforge.jp/projects/unf/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/unf_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/unf_ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.7.1.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.7.1.ebuild
new file mode 100644
index 00000000000..d4967f8d1c6
--- /dev/null
+++ b/dev-ruby/unf_ext/unf_ext-0.0.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Unicode Normalization Form support library for CRuby"
+HOMEPAGE="http://sourceforge.jp/projects/unf/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/unf_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/unf_ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}