summaryrefslogtreecommitdiff
path: root/dev-ruby/vlad
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/vlad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/vlad')
-rw-r--r--dev-ruby/vlad/Manifest3
-rw-r--r--dev-ruby/vlad/metadata.xml5
-rw-r--r--dev-ruby/vlad/vlad-2.6.3.ebuild29
-rw-r--r--dev-ruby/vlad/vlad-2.6.4.ebuild29
-rw-r--r--dev-ruby/vlad/vlad-2.6.5.ebuild29
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-ruby/vlad/Manifest b/dev-ruby/vlad/Manifest
new file mode 100644
index 00000000000..26a6a851b37
--- /dev/null
+++ b/dev-ruby/vlad/Manifest
@@ -0,0 +1,3 @@
+DIST vlad-2.6.3.gem 29184 SHA256 61d560f74c08844648fee9820c6d83da32c4c74e7ee541d15628151c3658889e SHA512 13246b98ee7238f1a5ff8ec9df3a1ecb3c137a1ab2e07af6f8a01c61ebc9798a6a1dd0f8080d31dcfff7d81268848868a6960939dd02713e585aeb732be95a52 WHIRLPOOL 525fb6b885c8f6dd20ec0f369ff6d8c973971bd65b36bb9ff99823cd7dd537f861fb4bf9b6540b07c23802b3fa1c30ceeef7789dcd7ffdd2540afe9b1d0331d5
+DIST vlad-2.6.4.gem 29184 SHA256 ad1c2cd8c0c9584aaa4061baaebfeba2df619e8c7ccbe25ff1e22b4696ea045d SHA512 e9d233c3caf01a7c77317e1bf64fb3832939fe5b85734874215160d9dd9b89967eeb80edc9ffdc4af47bc3f9c1b32eef77c29d99ad0535835c1a35cc55d5538e WHIRLPOOL ec730a456547e9c1e1f56c12fd5fa48f50eac04531f737ecb8c63c9fd7383cd7ee0748ffc34601bf6ed33cfe772dc61662aede26e7d097ba2d86025463e05348
+DIST vlad-2.6.5.gem 29184 SHA256 2447cce7b2db8695fcb9eb4fef5ed22932f217132e65ef95c3d66c5a07976044 SHA512 d1cf81372b973ad383cba7ad42512e9f734efc2034ae40ba6ef68277693c01568ee68613b97c8ead81793c748b848d5201f3b45cc00c16e3b460a95e42702f4f WHIRLPOOL 50942dd5fb0cff59da56613b146edc2bc565b5e755bfea8cc6dc0df9f3e9e73590ddc3063068df134cbfd1600e43cf0cd6b6a61dd41ebc5c2993c79910a75fcc
diff --git a/dev-ruby/vlad/metadata.xml b/dev-ruby/vlad/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/vlad/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/vlad/vlad-2.6.3.ebuild b/dev-ruby/vlad/vlad-2.6.3.ebuild
new file mode 100644
index 00000000000..838ff17050d
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2
+ test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/vlad/vlad-2.6.4.ebuild b/dev-ruby/vlad/vlad-2.6.4.ebuild
new file mode 100644
index 00000000000..838ff17050d
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2
+ test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/vlad/vlad-2.6.5.ebuild b/dev-ruby/vlad/vlad-2.6.5.ebuild
new file mode 100644
index 00000000000..7dd1ea2d83f
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.13
+ test? ( >=dev-ruby/minitest-5.7 )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.3"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}