summaryrefslogtreecommitdiff
path: root/dev-ruby/watch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/watch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/watch')
-rw-r--r--dev-ruby/watch/Manifest1
-rw-r--r--dev-ruby/watch/metadata.xml8
-rw-r--r--dev-ruby/watch/watch-0.1.0.ebuild18
3 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/watch/Manifest b/dev-ruby/watch/Manifest
new file mode 100644
index 00000000000..223067eb8cf
--- /dev/null
+++ b/dev-ruby/watch/Manifest
@@ -0,0 +1 @@
+DIST watch-0.1.0.gem 6656 SHA256 1d3e767cb917f226cb970ac0e39c9ee613f9082a390598bf94be516bbd79e409 SHA512 563a4733255eec5aae8df92c0844489934b948e3ef82de6e7a2117537c4de2e2ee53960331436b9297c53941cfa8885dd04550f57cc712141c5ca9714e72b818 WHIRLPOOL f6b6ef240cc8eee06e54a15c8c034ae9c108bd50b9e8c5144e1bc8149673de3238f7c8883c65640812c810b390ae19c06422114428dd9271d540917a65e7b99e
diff --git a/dev-ruby/watch/metadata.xml b/dev-ruby/watch/metadata.xml
new file mode 100644
index 00000000000..91c2b39687b
--- /dev/null
+++ b/dev-ruby/watch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">benschwarz/watch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/watch/watch-0.1.0.ebuild b/dev-ruby/watch/watch-0.1.0.ebuild
new file mode 100644
index 00000000000..ddcf098ce14
--- /dev/null
+++ b/dev-ruby/watch/watch-0.1.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A dirt simple mechanism to tell if files have changed"
+HOMEPAGE="http://github.com/benschwarz/watch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"