summaryrefslogtreecommitdiff
path: root/dev-ruby/websocket-driver
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/websocket-driver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/websocket-driver')
-rw-r--r--dev-ruby/websocket-driver/Manifest1
-rw-r--r--dev-ruby/websocket-driver/metadata.xml8
-rw-r--r--dev-ruby/websocket-driver/websocket-driver-0.3.4.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/websocket-driver/Manifest b/dev-ruby/websocket-driver/Manifest
new file mode 100644
index 00000000000..abd2c148ac3
--- /dev/null
+++ b/dev-ruby/websocket-driver/Manifest
@@ -0,0 +1 @@
+DIST websocket-driver-0.3.4.gem 19456 SHA256 b829ee1da54aa1374ca0cc143a83f1f5a55ea9f318021f06fec4b34a2f47b038 SHA512 c3c2c98bd5057a47e830fc31d56f88ad376ad71b473963fa20c1380de8a9c95b458cd9545b676f7adc1ed494664714648aec182b6b3681c38c87248370f1db64 WHIRLPOOL 019e6527dcd034ddfd3652c1f71bbeee01e62dfa59e7c70d1986b64bb05364122cc7d2c4bee2c2c0d4559e55724f6def40a1b20ad47e6fa153f5b7e8b3c0366d
diff --git a/dev-ruby/websocket-driver/metadata.xml b/dev-ruby/websocket-driver/metadata.xml
new file mode 100644
index 00000000000..80b360ff138
--- /dev/null
+++ b/dev-ruby/websocket-driver/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">faye/websocket-driver</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/websocket-driver/websocket-driver-0.3.4.ebuild b/dev-ruby/websocket-driver/websocket-driver-0.3.4.ebuild
new file mode 100644
index 00000000000..fe7cbeb0e9b
--- /dev/null
+++ b/dev-ruby/websocket-driver/websocket-driver-0.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A complete implementation of the WebSocket protocols"
+HOMEPAGE="https://github.com/faye/websocket-driver"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/websocket-driver extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/websocket-driver
+ cp ext/websocket-driver/websocket_mask.so lib/ || die
+}