summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-07 06:40:15 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-07 06:40:15 +0200
commit2642f7693a9996f5c7bde32537bc5d1e5a25c228 (patch)
tree7d5cd61e141aa9e97649a4d0b67e66d95b4589a6 /dev-ruby
parentc35df1c379f9c88cef81fed48bb448e7bd0a65ee (diff)
downloadgentoo-2642f7693a9996f5c7bde32537bc5d1e5a25c228.tar.gz
gentoo-2642f7693a9996f5c7bde32537bc5d1e5a25c228.tar.xz
dev-ruby/awesome_print: add 1.7.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/awesome_print/Manifest1
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.7.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/awesome_print/Manifest b/dev-ruby/awesome_print/Manifest
index 021fa7e64bc..669cb9bd3bf 100644
--- a/dev-ruby/awesome_print/Manifest
+++ b/dev-ruby/awesome_print/Manifest
@@ -1 +1,2 @@
DIST awesome_print-1.6.1.gem 32256 SHA256 0d8be8d9b270b900a337356cb9453ffdaf219d29902f14bbe4f120ecfdd38fef SHA512 394f5011d45f1daca77215e585d50c8505a63498b982aae32b206b99051fc27b903135fdb62976d9aeb4dfa80f5d6980b55c7fbe0fdc75feb979fd3b3b935c92 WHIRLPOOL 9d6c5f8fe60e3ba7ebbc16c5bcaf91337d2142d4846b490c75185c905ada1dd6f76fbd8f73a859bdeef91542ad3623758cfaa029d1b303dfc02d9b964199bc40
+DIST awesome_print-1.7.0.tar.gz 39436 SHA256 9f844b1f085718d5ba1968be79614dc93202b05166df4b09649e974db37e9634 SHA512 a49cf98c373ccc39a3f80b8ba531edb1f1bb63ba2dea10339aa3cdeae3e63863043c6a5fb0143569e1a50b2e340256210a170cccda3fc609aa3fccef20cfd080 WHIRLPOOL b6c9c5b3fde85618448145f050b7fe4cd9ea067c254bb25beb4dcc98e128597a1f2546022548d3a8502417f98bad04fb321021188ea7211e0087380dd56db225
diff --git a/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild b/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild
new file mode 100644
index 00000000000..bea73ff73b8
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to pretty print Ruby objects in full color with proper indentation"
+HOMEPAGE="https://github.com/awesome-print/awesome_print"
+SRC_URI="https://github.com/awesome-print/awesome_print/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/codeclimate/I s:^:#:' spec/spec_helper.rb || die
+}