summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-05 13:56:50 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-05 14:13:53 +0200
commit7a3c7bf400dddaf1e6fa9220470f77509b9e8dd0 (patch)
tree3e58145880efefda487973828b41bb6abc2116b9 /dev-ruby
parent07e90c3617fe22f12f8a676a03f6b32b8a35f953 (diff)
downloadgentoo-7a3c7bf400dddaf1e6fa9220470f77509b9e8dd0.tar.gz
gentoo-7a3c7bf400dddaf1e6fa9220470f77509b9e8dd0.tar.xz
dev-ruby/hashie: add ruby23 revision
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hashie/hashie-3.4.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-3.4.4-r1.ebuild b/dev-ruby/hashie/hashie-3.4.4-r1.ebuild
new file mode 100644
index 00000000000..f2200822b8a
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.4.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
+
+ # Avoid dependency on rspec-pending_for and its dependencies
+ sed -i -e '/pending_for/ s:^:#:' \
+ spec/spec_helper.rb \
+ spec/hashie/mash_spec.rb \
+ spec/hashie/extensions/strict_key_access_spec.rb || die
+}