summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:45:00 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:45:00 -0400
commitb6e53d7a2dd401132742b9e003b39ace2829ef4a (patch)
treee72854587b2a707a925bce26532de159d5077428 /dev-ruby
parentd61dc2a4258d03aeb20620b912bfa2b4e21cf52c (diff)
downloadgentoo-b6e53d7a2dd401132742b9e003b39ace2829ef4a.tar.gz
gentoo-b6e53d7a2dd401132742b9e003b39ace2829ef4a.tar.xz
dev-ruby/metasploit-credential: fix improperly imported ebuild from Pentoo
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild24
1 files changed, 0 insertions, 24 deletions
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild
index 98db6b6be7e..7836550e5b2 100644
--- a/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild
+++ b/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild
@@ -26,27 +26,3 @@ ruby_add_rdepend ">=dev-ruby/metasploit-concern-1.0.0:1.0
>=dev-ruby/railties-4.0.9:4.0
dev-ruby/net-ssh
dev-ruby/pg"
-ruby_add_bdepend "dev-ruby/bundler"
-
-all_ruby_prepare() {
- [ -f Gemfile.lock ] && rm Gemfile.lock
- #For now, we don't support development or testing at all
- #if ! use development; then
- sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
- sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
- #fi
- #if ! use test; then
- sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
- #fi
- #if ! use test && ! use development; then
- sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
- #fi
-}
-
-each_ruby_prepare() {
- if [ -f Gemfile ]
- then
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
- fi
-}