summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-25 07:20:58 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-25 07:20:58 +0200
commitfa500e6e0bf7606c26f39b560eab3fab318a2447 (patch)
treece09a848a04180d5b0c88bc632ebbae5c643698a /dev-ruby
parent8a211ec9eef0b84b95d1c5db5062dfc571f65a68 (diff)
downloadgentoo-fa500e6e0bf7606c26f39b560eab3fab318a2447.tar.gz
gentoo-fa500e6e0bf7606c26f39b560eab3fab318a2447.tar.xz
dev-ruby/asciidoctor-diagram: add 1.5.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/asciidoctor-diagram/Manifest1
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/Manifest b/dev-ruby/asciidoctor-diagram/Manifest
index fd2fd9c45ba..c14e3f99a0e 100644
--- a/dev-ruby/asciidoctor-diagram/Manifest
+++ b/dev-ruby/asciidoctor-diagram/Manifest
@@ -1 +1,2 @@
DIST asciidoctor-diagram-1.4.0.tar.gz 2950518 SHA256 83243bada230f2d71a7aae5df0edea8b418979d5f10a29b46b912f36a96e3edc SHA512 9e392ad419dd73741ec12ff252d48e043151a222b2cb6b0947eef8ef87356bbf184a6caa7ab595862255e5913c2390c3d90f26b20b4a0d2a91dab79a6a65075d WHIRLPOOL 9a5ea2931ee088eab6e8c2d347d1f14a27b86a274e3cead240e9cba8a968bfef52c7fcb008092467c57cc5f99a5efcef21ea6138f4d5cb7e870658b879831ec9
+DIST asciidoctor-diagram-1.5.1.tar.gz 5081222 SHA256 c37eadec781c339d00e08c0d6a3ee7f8101a46fe17da94afad0fa6a2c0b57898 SHA512 140fbde07f3873cf710d95b055cf062d651e3eda5a77e434fa6a1c122894425d29ef9ae3583ab1dbb5ba6e1a360cad73afd1d704bebdebdff6c05650ed90a61c WHIRLPOOL d7e45604d96c3550ca16cc447e62ed3dd426c03366f521d4caa422cbe4952bbdcd807081b8fbd55171af0cb9cf79394e467641f96394a55b05f9674fc77bfe5d
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.1.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.1.ebuild
new file mode 100644
index 00000000000..5bdb707c44d
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/asciidoctor-1.5.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{blockdiag,mermaid,shaape,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}