summaryrefslogtreecommitdiff
path: root/dev-scheme/guile
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-09-18 23:58:54 -0600
committerRyan Hill <rhill@gentoo.org>2015-10-12 17:26:15 -0600
commitdb9b115582ff1e2135acda0f3e74d79bc6b093fd (patch)
tree9f601606be43f2ef0340f9ea8a9173874721f75c /dev-scheme/guile
parent827c7b55b865c20157d0ad17b6883b15cd5167bb (diff)
downloadgentoo-db9b115582ff1e2135acda0f3e74d79bc6b093fd.tar.gz
gentoo-db9b115582ff1e2135acda0f3e74d79bc6b093fd.tar.xz
dev-scheme/guile: Make building guile-readline optional (bug #392553)
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/files/guile-1.8.8-readline.patch34
-rw-r--r--dev-scheme/guile/guile-1.8.8-r2.ebuild8
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-scheme/guile/files/guile-1.8.8-readline.patch b/dev-scheme/guile/files/guile-1.8.8-readline.patch
new file mode 100644
index 00000000000..68f64c528a4
--- /dev/null
+++ b/dev-scheme/guile/files/guile-1.8.8-readline.patch
@@ -0,0 +1,34 @@
+Make guile-readline optional
+
+https://bugs.gentoo.org/392553
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -24,7 +24,7 @@
+ #
+ AUTOMAKE_OPTIONS = 1.10
+
+-SUBDIRS = oop libguile ice-9 guile-config guile-readline emacs \
++SUBDIRS = oop libguile ice-9 guile-config @GUILE_READLINE@ emacs \
+ scripts srfi doc examples test-suite benchmark-suite lang am
+
+ bin_SCRIPTS = guile-tools
+--- a/configure.in
++++ b/configure.in
+@@ -57,7 +57,15 @@ AH_TOP(/*GUILE_CONFIGURE_COPYRIGHT*/)
+ #
+ #--------------------------------------------------------------------
+
+-AC_CONFIG_SUBDIRS(guile-readline)
++GUILE_READLINE=
++AC_ARG_ENABLE([readline],
++ [AS_HELP_STRING([--disable-readline],
++ [disable building guile-readline])],
++ if test "x$enable_readline" != xno; then
++ AC_CONFIG_SUBDIRS([guile-readline])
++ GUILE_READLINE="guile-readline"
++ fi)
++AC_SUBST([GUILE_READLINE])
+
+ #--------------------------------------------------------------------
+
diff --git a/dev-scheme/guile/guile-1.8.8-r2.ebuild b/dev-scheme/guile/guile-1.8.8-r2.ebuild
index 2856054af76..b6381265a65 100644
--- a/dev-scheme/guile/guile-1.8.8-r2.ebuild
+++ b/dev-scheme/guile/guile-1.8.8-r2.ebuild
@@ -11,7 +11,8 @@ SRC_URI="mirror://gnu/guile/${P}.tar.gz"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="networking +regex discouraged +deprecated emacs nls debug-freelist debug-malloc debug +threads"
+IUSE="debug debug-freelist debug-malloc +deprecated discouraged emacs networking nls readline +regex +threads"
+
RESTRICT="!regex? ( test )"
RDEPEND="
@@ -19,7 +20,8 @@ RDEPEND="
dev-libs/libltdl:0=
sys-devel/gettext
sys-libs/ncurses:0=
- emacs? ( virtual/emacs )"
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}
sys-apps/texinfo
sys-devel/libtool"
@@ -36,6 +38,7 @@ src_prepare() {
"${FILESDIR}/${P}-gcc5.patch" \
"${FILESDIR}/${P}-makeinfo-5.patch" \
"${FILESDIR}/${P}-gtexinfo-5.patch" \
+ "${FILESDIR}/${P}-readline.patch" \
"${FILESDIR}/${P}-tinfo.patch" \
"${FILESDIR}/${P}-sandbox.patch"
@@ -62,6 +65,7 @@ src_configure() {
--disable-static \
--enable-posix \
$(use_enable networking) \
+ $(use_enable readline) \
$(use_enable regex) \
$(use deprecated || use_enable discouraged) \
$(use_enable deprecated) \