summaryrefslogtreecommitdiff
path: root/dev-tex/chktex/chktex-1.7.3.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/chktex/chktex-1.7.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/chktex/chktex-1.7.3.ebuild')
-rw-r--r--dev-tex/chktex/chktex-1.7.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-tex/chktex/chktex-1.7.3.ebuild b/dev-tex/chktex/chktex-1.7.3.ebuild
new file mode 100644
index 00000000000..cca1bf4786d
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.7.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="http://download.savannah.gnu.org/releases/chktex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc +pcre test"
+# Tests fail without pcre. Enable pcre by default and make tests depend on it.
+REQUIRED_USE="test? ( pcre )"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ doc? ( dev-tex/latex2html )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.1-asneeded.patch" )
+DOCS=( NEWS )
+
+src_configure() {
+ export VARTEXFONTS="${T}/fonts" #538672
+
+ local myeconfargs=(
+ $(use_enable debug debug-info)
+ $(use_enable pcre)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
+ DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ fi
+ autotools-utils_src_install
+ doman *.1
+}