summaryrefslogtreecommitdiff
path: root/dev-tex/dvi2tty/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/dvi2tty/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/dvi2tty/files')
-rw-r--r--dev-tex/dvi2tty/files/dvi2tty-5.3.4-cflags.patch29
-rw-r--r--dev-tex/dvi2tty/files/dvi2tty-cflags.patch30
-rw-r--r--dev-tex/dvi2tty/files/dvi2tty-gcc.patch12
-rw-r--r--dev-tex/dvi2tty/files/dvi2tty-getline.patch67
4 files changed, 138 insertions, 0 deletions
diff --git a/dev-tex/dvi2tty/files/dvi2tty-5.3.4-cflags.patch b/dev-tex/dvi2tty/files/dvi2tty-5.3.4-cflags.patch
new file mode 100644
index 00000000000..1d46f195453
--- /dev/null
+++ b/dev-tex/dvi2tty/files/dvi2tty-5.3.4-cflags.patch
@@ -0,0 +1,29 @@
+--- Makefile
++++ Makefile
+@@ -6,11 +6,10 @@
+ # This Makefile does not work for MSDOS. Make your
+ # own one, or compile by hand.
+ #
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -Wall -O2
++CFLAGS += -Wall
+ # CFLAGS = -Wall -O2 -fomit-frame-pointer
+-LDFLAGS = -s
+
+ prefix = ${DESTDIR}/usr
+ mandir = $(prefix)/share/man/man1
+@@ -20,10 +19,10 @@
+ all: dvi2tty disdvi
+
+ dvi2tty:dvi2tty.o dvistuff.o
+- $(CC) $(LFLAGS) -o dvi2tty dvi2tty.o dvistuff.o
++ $(CC) $(LDFLAGS) -o dvi2tty dvi2tty.o dvistuff.o
+
+ disdvi:disdvi.o
+- $(CC) $(LFLAGS) -o disdvi disdvi.o
++ $(CC) $(LDFLAGS) -o disdvi disdvi.o
+
+ dvi2tty.o: dvi2tty.c dvi2tty.h
+
diff --git a/dev-tex/dvi2tty/files/dvi2tty-cflags.patch b/dev-tex/dvi2tty/files/dvi2tty-cflags.patch
new file mode 100644
index 00000000000..36d9afb7f1e
--- /dev/null
+++ b/dev-tex/dvi2tty/files/dvi2tty-cflags.patch
@@ -0,0 +1,30 @@
+Index: dvi2tty-5.3.1/Makefile
+===================================================================
+--- dvi2tty-5.3.1.orig/Makefile
++++ dvi2tty-5.3.1/Makefile
+@@ -6,11 +6,11 @@
+ # This Makefile does not work for MSDOS. Make your
+ # own one, or compile by hand.
+ #
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -Wall -O2
++CFLAGS ?= -Wall -O2
+ # CFLAGS = -Wall -O2 -fomit-frame-pointer
+-LDFLAGS = -s
++#LDFLAGS = -s
+
+ prefix = /usr/local
+ mandir = $(prefix)/man/man1
+@@ -20,10 +20,8 @@ bindir = $(prefix)/bin
+ all: dvi2tty disdvi
+
+ dvi2tty:dvi2tty.o dvistuff.o
+- $(CC) $(LFLAGS) -o dvi2tty dvi2tty.o dvistuff.o
+
+ disdvi:disdvi.o
+- $(CC) $(LFLAGS) -o disdvi disdvi.o
+
+ dvi2tty.o: dvi2tty.c dvi2tty.h
+
diff --git a/dev-tex/dvi2tty/files/dvi2tty-gcc.patch b/dev-tex/dvi2tty/files/dvi2tty-gcc.patch
new file mode 100644
index 00000000000..38ec70309cc
--- /dev/null
+++ b/dev-tex/dvi2tty/files/dvi2tty-gcc.patch
@@ -0,0 +1,12 @@
+diff -ur dvi2tty-5.3.1-old/disdvi.c dvi2tty-5.3.1/disdvi.c
+--- dvi2tty-5.3.1-old/disdvi.c 2003-01-23 17:31:00.000000000 +0700
++++ dvi2tty-5.3.1/disdvi.c 2004-12-16 18:59:50.930219880 +0700
+@@ -108,7 +108,7 @@
+ */
+
+ #if !defined(THINK_C)
+-char * malloc ();
++void * malloc ();
+ #endif
+
+ #if defined(VMS)
diff --git a/dev-tex/dvi2tty/files/dvi2tty-getline.patch b/dev-tex/dvi2tty/files/dvi2tty-getline.patch
new file mode 100644
index 00000000000..932810ea40a
--- /dev/null
+++ b/dev-tex/dvi2tty/files/dvi2tty-getline.patch
@@ -0,0 +1,67 @@
+http://bugs.gentoo.org/271621
+
+--- dvi2tty-5.3.1-orig/dvistuff.c 2003-01-23 04:01:12.000000000 +0100
++++ dvi2tty-5.3.1/dvistuff.c 2009-06-03 15:57:26.000000000 +0200
+@@ -179,7 +179,7 @@
+ void ruleaux (long, long, char);
+ long horizontalmove (long);
+ int skipnops (void);
+-linetype * getline (void);
++linetype * get_line (void);
+ linetype * findline (void);
+ unsigned long num (int);
+ long snum (int);
+@@ -208,7 +208,7 @@
+ void ruleaux (long rulewt, long ruleht, char ch);
+ long horizontalmove (long amount);
+ int skipnops (void);
+-linetype * getline (void);
++linetype * get_line (void);
+ linetype * findline (void);
+ unsigned long num (int size);
+ long snum (int size);
+@@ -376,7 +376,7 @@
+ h = 0L; v = 0L; /* initialize coordinates */
+ x = 0L; w = 0L; y = 0L; z = 0L; /* initialize amounts */
+ sptr = 0; /* initialize stack */
+- currentline = getline(); /* initialize list of lines */
++ currentline = get_line(); /* initialize list of lines */
+ currentline->vv = 0L;
+ firstline = currentline;
+ lastline = currentline;
+@@ -777,7 +777,7 @@
+ * GETLINE -- Returns an initialized line-object
+ */
+
+-linetype *getline(void)
++linetype *get_line(void)
+ {
+ register int i;
+ register linetype *temp;
+@@ -809,7 +809,7 @@
+
+ if (v <= firstline->vv) { /* above first line */
+ if (firstline->vv - v > lineheight) {
+- temp = getline();
++ temp = get_line();
+ temp->next = firstline;
+ firstline->prev = temp;
+ temp->vv = v;
+@@ -820,7 +820,7 @@
+
+ if (v >= lastline->vv) { /* below last line */
+ if (v - lastline->vv > lineheight) {
+- temp = getline();
++ temp = get_line();
+ temp->prev = lastline;
+ lastline->next = temp;
+ temp->vv = v;
+@@ -843,7 +843,7 @@
+ return temp->next;
+
+ /* no line fits suitable, generate a new one */
+- currentline = getline();
++ currentline = get_line();
+ currentline->next = temp->next;
+ currentline->prev = temp;
+ temp->next->prev = currentline;