summaryrefslogtreecommitdiff
path: root/dev-tex/feynmf
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/feynmf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/feynmf')
-rw-r--r--dev-tex/feynmf/Manifest2
-rw-r--r--dev-tex/feynmf/feynmf-1.08-r3.ebuild46
-rw-r--r--dev-tex/feynmf/feynmf-1.08-r4.ebuild56
-rw-r--r--dev-tex/feynmf/files/feynmf-1.08-tempfile.patch33
-rw-r--r--dev-tex/feynmf/files/feynmf-1.08.patch12
-rw-r--r--dev-tex/feynmf/metadata.xml14
6 files changed, 163 insertions, 0 deletions
diff --git a/dev-tex/feynmf/Manifest b/dev-tex/feynmf/Manifest
new file mode 100644
index 00000000000..6c5603c929d
--- /dev/null
+++ b/dev-tex/feynmf/Manifest
@@ -0,0 +1,2 @@
+DIST feynmf-1.08.tar.gz 286208 SHA256 07bd8c23246fc3e8c7bab6590570e601dcbab2e7b07119cc052693c06d31bd0f SHA512 968853ef09ab140fa0844068e564995b44bd79bbe5376a7b866d6db80278b2099aab47920213c7f744d5558e10e69a6de8e056f4d35c8d0fe51055a17981cad2 WHIRLPOOL f83c8e7fc6de3f5d7be55ae621a96230abdbd77892f8f76b66f70feee6115bcb51456dd0dd44e21b24f032060eb1d6aa012ea7576dbbb56d70ff309a060aef37
+DIST feynmf-cnl.tar.gz 49920 SHA256 18bbfc2aedcb76f20c8817a1ee002962baa1172f5b2c9fb23f968268db2c75d5 SHA512 ba84d284a6157bd1fce6fd1752a006472631bd8628d9c7b0cd9f429e7d3f5c79a7489c43d9db76232987cbe8de01a794d060095dbcbffbd003189ff002493201 WHIRLPOOL 7bb8df35942ef79aa93591b6980051e7f86e4c244557b8645c125b9bc4db6ad6e7aac035e8ba4bfc9b9614b777159e62be74d21c9b4181f52f412ba2f91465fe
diff --git a/dev-tex/feynmf/feynmf-1.08-r3.ebuild b/dev-tex/feynmf/feynmf-1.08-r3.ebuild
new file mode 100644
index 00000000000..4fc43489e43
--- /dev/null
+++ b/dev-tex/feynmf/feynmf-1.08-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils latex-package
+
+DESCRIPTION="Combined LaTeX/Metafont package for drawing of Feynman diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/feynmf/"
+#Taken from: ftp.tug.ctan.org/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz
+ doc? ( http://dev.gentoo.org/~ulm/distfiles/${PN}-cnl.tar.gz )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-texlive/texlive-metapost"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${PN}"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${P}-tempfile.patch"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake MP=mpost all manual.ps
+ use doc && emake -f Makefile.cnl ps
+}
+
+src_install() {
+ newbin feynmf.pl feynmf
+ doman feynmf.1
+ insinto ${TEXMF}/tex/latex/${PN}; doins feynmf.sty feynmp.sty
+ insinto ${TEXMF}/metafont/${PN}; doins feynmf.mf
+ insinto ${TEXMF}/metapost/${PN}; doins feynmp.mp
+ dodoc README manual.ps template.tex
+ use doc && dodoc fmfcnl*.ps
+}
diff --git a/dev-tex/feynmf/feynmf-1.08-r4.ebuild b/dev-tex/feynmf/feynmf-1.08-r4.ebuild
new file mode 100644
index 00000000000..728d774b07e
--- /dev/null
+++ b/dev-tex/feynmf/feynmf-1.08-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils latex-package
+
+DESCRIPTION="Combined LaTeX/Metafont package for drawing of Feynman diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/feynmf/"
+#Taken from: ftp.tug.ctan.org/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz
+ doc? ( http://dev.gentoo.org/~ulm/distfiles/${PN}-cnl.tar.gz )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-texlive/texlive-metapost"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${P}-tempfile.patch"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake MP=mpost all manual.ps
+ use doc && emake -f Makefile.cnl ps
+}
+
+src_install() {
+ newbin feynmf.pl feynmf
+ doman feynmf.1
+ insinto ${TEXMF}/tex/latex/${PN}; doins feynmf.sty feynmp.sty
+ insinto ${TEXMF}/metafont/${PN}; doins feynmf.mf
+ insinto ${TEXMF}/metapost/${PN}; doins feynmp.mp
+ dodoc README manual.ps template.tex
+ docompress -x /usr/share/doc/${PF}/manual.ps
+ dosym /usr/share/doc/${PF}/manual.ps \
+ ${TEXMF}/doc/latex/${PN}/${PN}-manual.ps
+
+ if use doc; then
+ local f
+ for f in fmfcnl*.ps; do
+ dodoc ${f}
+ docompress -x /usr/share/doc/${PF}/${f}
+ dosym /usr/share/doc/${PF}/${f} ${TEXMF}/doc/latex/${PN}/${f}
+ done
+ fi
+}
diff --git a/dev-tex/feynmf/files/feynmf-1.08-tempfile.patch b/dev-tex/feynmf/files/feynmf-1.08-tempfile.patch
new file mode 100644
index 00000000000..5e3ec840dcc
--- /dev/null
+++ b/dev-tex/feynmf/files/feynmf-1.08-tempfile.patch
@@ -0,0 +1,33 @@
+--- feynmf-orig/feynmf.pl 2007-11-06 08:32:37.000000000 +0100
++++ feynmf/feynmf.pl 2007-11-06 09:33:04.000000000 +0100
+@@ -119,6 +119,7 @@
+ require 5.000;
+ # use strict;
+ use File::Find;
++use File::Temp qw(tempfile);
+ use Getopt::Long;
+
+ ########################################################################
+@@ -270,18 +271,18 @@
+ my @tfm = @_;
+ # Prepare a fake temporary PL file
+ # (/dev/null won't do, because the font must not be empty):
+- my ($pl) = "/tmp/feynmf$$.pl";
+ my ($tfm);
+ $pltotf_prog
+ or die "feynmf: fatal: pltopf programm required unless -notfm\n";
+- open (PL, ">$pl") or die "feynmf: can't open temporary file $pl: $!\n";
++ my ($PL, $pl) = tempfile("/tmp/feynmfXXXXXX", SUFFIX => ".pl");
++ $PL or die "feynmf: can't open temporary file: $!\n";
+ push @temporay_files, $pl;
+- print PL <<__END_PL__;
++ print $PL <<__END_PL__;
+ (FAMILY FEYNMF)
+ (DESIGNSIZE R 10.0)
+ (CHARACTER D 1 (CHARWD R 10.0) (CHARHT R 10.0))
+ __END_PL__
+- close (PL);
++ close ($PL);
+ foreach $tfm (@tfm) {
+ maybe_run "$pltotf_prog $pl $tfm.tfm" unless -r "$tfm.tfm";
+ }
diff --git a/dev-tex/feynmf/files/feynmf-1.08.patch b/dev-tex/feynmf/files/feynmf-1.08.patch
new file mode 100644
index 00000000000..9695d26c26a
--- /dev/null
+++ b/dev-tex/feynmf/files/feynmf-1.08.patch
@@ -0,0 +1,12 @@
+diff -Nur feynmf-orig/feynmf.pl feynmf/feynmf.pl
+--- feynmf-orig/feynmf.pl 1996-12-02 01:00:00.000000000 +0100
++++ feynmf/feynmf.pl 2004-09-02 23:25:40.603910119 +0200
+@@ -373,7 +373,7 @@
+ maybe_run "$gftopk_prog $gf" if $gftopk_prog;
+ }
+ }
+- close (<LOG>);
++ close (LOG);
+ }
+ }
+ }
diff --git a/dev-tex/feynmf/metadata.xml b/dev-tex/feynmf/metadata.xml
new file mode 100644
index 00000000000..2ffe56d5544
--- /dev/null
+++ b/dev-tex/feynmf/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription>
+ FeynMF is a combined LaTeX/Metafont package for easy drawing of professional
+ quality Feynman diagrams. FeynMF lays out most diagrams satisfactorily from
+ the structure of the graph without any need for manual intervention.
+ Nevertheless all the power of Metafont is available for more obscure cases.
+</longdescription>
+</pkgmetadata>