summaryrefslogtreecommitdiff
path: root/dev-tex/latexmk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/latexmk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/latexmk')
-rw-r--r--dev-tex/latexmk/Manifest3
-rw-r--r--dev-tex/latexmk/files/completion.bash-245
-rw-r--r--dev-tex/latexmk/latexmk-435.ebuild31
-rw-r--r--dev-tex/latexmk/latexmk-441.ebuild30
-rw-r--r--dev-tex/latexmk/latexmk-443a.ebuild30
-rw-r--r--dev-tex/latexmk/metadata.xml5
6 files changed, 144 insertions, 0 deletions
diff --git a/dev-tex/latexmk/Manifest b/dev-tex/latexmk/Manifest
new file mode 100644
index 00000000000..b224dc68ffe
--- /dev/null
+++ b/dev-tex/latexmk/Manifest
@@ -0,0 +1,3 @@
+DIST latexmk-435.zip 386766 SHA256 9de9ebdafd5e0cf5c29235ec6316aae2a039a5a6eb6d55e83b4cfbb7374d7fc3 SHA512 ff8f88c261e2b90663d979ddcb373f777fd3ad4b125ab703052867b4896257b34033ed2a07fd4574da526d839449512ccc898bcb9aaf81ae5afb442dcb8622be WHIRLPOOL 0bbf295edd8eb079160af834057abe2e02f536868b3815c265a2f7320eb8122701f062f8c784bf087e1cba9391ff755118c516a9ed1455fbbebab6334c41db6f
+DIST latexmk-441.zip 425737 SHA256 564b56414ab3a71ab39d01becce95deed4f262e061de167d0cca03c8ba8e5d46 SHA512 b9b65ebda1edc6f1f2692f7c8f02eeeac07dc2bd2f5d96c763615a9e27918069ba65809e5e61580e541420bf1f8d7edc451ad3f1753d43e9596175fdb3571a73 WHIRLPOOL bd48511ebf823709e66be3b82d6b0e8038a8450dfc3217b7e4f0612e6f4ee9d286e38696171337e165fb246464160290cd82e35f7a7e74962037821989e32634
+DIST latexmk-443a.zip 434070 SHA256 e410d295c0a47327b953ece5b582c294359bdf89138ef990d5621b020ff2bbe5 SHA512 9791bea6341f92988b6a7bdc4cd1587d1b8c6e013d9e7a3be219ea4045a8f95971072cf6633998839c35a462b2e5843adf3d5893519f1f6c2bd4ecf81314b2c0 WHIRLPOOL 9662ac695de7c3ead43f23abcc92bb611cb089ddaa475b36ab8b3b957cf7e8c864e9cc0d8d037e8fafedc44161112ff868ec3612f84bc3d338c5e2422f49e246
diff --git a/dev-tex/latexmk/files/completion.bash-2 b/dev-tex/latexmk/files/completion.bash-2
new file mode 100644
index 00000000000..a24b7a81915
--- /dev/null
+++ b/dev-tex/latexmk/files/completion.bash-2
@@ -0,0 +1,45 @@
+#! /bin/bash
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+
+# bash_completion for latexmk
+#
+#
+# Author: Christoph Junghans
+# ottxor@gentoo.org
+#
+# Revision history:
+# 0.1 26-05-10 --- initial version
+# 0.2 15-02-11 --- clean up
+#
+# HOWTO:
+# source this file to enable it
+
+_latexmk()
+{
+ local cur output aopts opts prev
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ output=$( $1 -help 2> /dev/null)
+ #options with args ,pattern: ^ (-XXX) <YYYY>.*$
+ aopts=" $( echo " $output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\)[[:space:]]\+<[^>]\+>.*$/\1/p' | sort -u | tr '\n' ' ')"
+ #if previous option in in $aopts
+ if [[ -n "$prev" ]] && [[ -z "${aopts//* $prev *}" ]]; then
+ #argument of $prev ,pattern: ^ -XXX (<YYYY>).*$
+ opts=$(echo "$output" | sed -n "s/^[[:space:]]\+$prev[[:space:]]\+\(<[^>]\+>\).*\$/\1/p")
+ COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
+ elif [[ "$cur" == -* ]]; then
+ #all options, pattern: ^ (-XXX).*$
+ opts=$( echo "$output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\).*$/\1/p'| sort -u )
+ COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
+ else
+ #filenames *.tex and dirs, rest is done by '-o filenames' below
+ COMPREPLY=( $( eval compgen -f -X "!*.tex" -- ${cur} ) $( compgen -d -- $cur ) )
+ fi
+}
+
+complete -F _latexmk -o filenames latexmk
diff --git a/dev-tex/latexmk/latexmk-435.ebuild b/dev-tex/latexmk/latexmk-435.ebuild
new file mode 100644
index 00000000000..b26297e198c
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-435.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}
diff --git a/dev-tex/latexmk/latexmk-441.ebuild b/dev-tex/latexmk/latexmk-441.ebuild
new file mode 100644
index 00000000000..5f88af142a8
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-441.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}
diff --git a/dev-tex/latexmk/latexmk-443a.ebuild b/dev-tex/latexmk/latexmk-443a.ebuild
new file mode 100644
index 00000000000..dfedd7bd9d5
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-443a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}
diff --git a/dev-tex/latexmk/metadata.xml b/dev-tex/latexmk/metadata.xml
new file mode 100644
index 00000000000..21ff3a53848
--- /dev/null
+++ b/dev-tex/latexmk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+</pkgmetadata>