summaryrefslogtreecommitdiff
path: root/dev-tex/minted
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/minted
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/minted')
-rw-r--r--dev-tex/minted/Manifest2
-rw-r--r--dev-tex/minted/metadata.xml11
-rw-r--r--dev-tex/minted/minted-1.7.ebuild28
-rw-r--r--dev-tex/minted/minted-2.0.ebuild28
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-tex/minted/Manifest b/dev-tex/minted/Manifest
new file mode 100644
index 00000000000..a1c73b06c8c
--- /dev/null
+++ b/dev-tex/minted/Manifest
@@ -0,0 +1,2 @@
+DIST minted-2.0.tar.gz 1039735 SHA256 a54daeb9d5e5d1150bb75f252d5f81ff5b3d13b1d6528261ac80dd9245813fe7 SHA512 1e874a865da24d9d890d68f9a7d7fed710746993534903cd04a518e3d65003f65efca47c4cd563bda70b3eb1356e609f5e662a0d762248c7b722b8c5aebda6de WHIRLPOOL dd01416ea13e7f862de3ee8ee84b28b5f5d1f9020b5c01afb40c382016053bd79beed86b1500328bc29e95161dfed0e179df9e311e3d338f12d8f62b18549e80
+DIST minted-v1.7.zip 363605 SHA256 71113736bbc44fdf619dce95fdd3b0f5d870117574212bd9dbe08ef95547790e SHA512 6f1b3af3d5bd3fb8d3c2a9c6ae595a28a69cc733106d241cb258d61a89da70866eeeed7f3b6023c64246161c2c10689cac5ae56fcde73cea891133d08e521d63 WHIRLPOOL d74cb7eea25b19c96770a4d6e50c44bf7b11bb68d3ab5575b2cf30036187baaac51ba8026342308bbbac20783d2659c0347d16d0ef5ae2ee0fac4c0aa248ce0f
diff --git a/dev-tex/minted/metadata.xml b/dev-tex/minted/metadata.xml
new file mode 100644
index 00000000000..948f2f07b8a
--- /dev/null
+++ b/dev-tex/minted/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gpoore/minted</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/minted/minted-1.7.ebuild b/dev-tex/minted/minted-1.7.ebuild
new file mode 100644
index 00000000000..7a9530b5719
--- /dev/null
+++ b/dev-tex/minted/minted-1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX package that facilitates expressive syntax highlighting in using the powerful Pygments library"
+HOMEPAGE="https://code.google.com/p/minted/"
+SRC_URI="https://minted.googlecode.com/files/${PN}-v${PV}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ dev-texlive/texlive-latexextra
+ dev-python/pygments"
+
+S="${WORKDIR}"/
+
+src_install() {
+ latex-package_src_install
+ dodoc README
+}
diff --git a/dev-tex/minted/minted-2.0.ebuild b/dev-tex/minted/minted-2.0.ebuild
new file mode 100644
index 00000000000..092029f8db0
--- /dev/null
+++ b/dev-tex/minted/minted-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX package that facilitates expressive syntax highlighting in using the powerful Pygments library"
+HOMEPAGE="https://github.com/gpoore/minted"
+SRC_URI="https://github.com/gpoore/minted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ dev-texlive/texlive-latexextra
+ dev-python/pygments"
+
+S="${WORKDIR}"/${P}/source
+
+src_install() {
+ latex-package_src_install
+ dodoc "${S}"/../*md
+}