summaryrefslogtreecommitdiff
path: root/dev-util/bdelta/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bdelta/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bdelta/files')
-rw-r--r--dev-util/bdelta/files/bdelta-0.3.1-soname.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/bdelta/files/bdelta-0.3.1-soname.patch b/dev-util/bdelta/files/bdelta-0.3.1-soname.patch
new file mode 100644
index 00000000000..360a16d7c0d
--- /dev/null
+++ b/dev-util/bdelta/files/bdelta-0.3.1-soname.patch
@@ -0,0 +1,21 @@
+diff --git a/src/Makefile b/src/Makefile
+index 65fb88d..3b4a261 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,6 +3,7 @@ PREFIX ?= /usr
+ BINDIR ?= $(PREFIX)/bin
+ LIBDIR ?= ${PREFIX}/lib
+ CXXFLAGS += -O2
++DYLIB_LDFLAGS ?= -Wl,-soname,libbdelta.so
+
+ ifeq ($(shell uname -s),Darwin)
+ SHAREDLIB := libbdelta.dylib
+@@ -19,7 +20,7 @@ libbdelta.a: libbdelta.cpp compatibility.h checksum.h file.h
+ $(AR) rs $@ $<.o
+
+ libbdelta.so: libbdelta.cpp compatibility.h checksum.h file.h
+- $(CXX) -shared -fPIC $(CXXFLAGS) $(LDFLAGS) $< -o $@
++ $(CXX) -shared -fPIC $(CXXFLAGS) $(LDFLAGS) $(DYLIB_LDFLAGS) $< -o $@
+
+ libbdelta.dylib: libbdelta.cpp compatibility.h checksum.h file.h
+ $(CXX) -dynamiclib $(CXXFLAGS) $< -o $@