summaryrefslogtreecommitdiff
path: root/dev-util/cflow
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cflow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cflow')
-rw-r--r--dev-util/cflow/Manifest1
-rw-r--r--dev-util/cflow/cflow-1.4.ebuild60
-rw-r--r--dev-util/cflow/files/50cflow-gentoo.el6
-rw-r--r--dev-util/cflow/files/cflow-1.4-info-direntry.patch13
-rw-r--r--dev-util/cflow/metadata.xml15
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-util/cflow/Manifest b/dev-util/cflow/Manifest
new file mode 100644
index 00000000000..4af7b60eec7
--- /dev/null
+++ b/dev-util/cflow/Manifest
@@ -0,0 +1 @@
+DIST cflow-1.4.tar.bz2 634862 SHA256 037e39d6048ea91c68a5f3a561e10f22fd085d1f7641643e19c831a94ec26bca SHA512 b8f8bd0e75e9ad0ba112313c576766b7cf72ef1e29ad0b0a2ce233f43b4196e311077be2134ff6e0fa0bb18375469ca6a969307fa7565a63ab60dec20400ee03 WHIRLPOOL fb1b7ef812c18b0732126a3a624cfba6de6abbdc419717c4d1dc403717e6200dfe85f3189d65547391679f846c6044a7407bde1339201596c67f61023d307255
diff --git a/dev-util/cflow/cflow-1.4.ebuild b/dev-util/cflow/cflow-1.4.ebuild
new file mode 100644
index 00000000000..f3524abf2f4
--- /dev/null
+++ b/dev-util/cflow/cflow-1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit elisp-common eutils
+
+DESCRIPTION="C function call hierarchy analyzer"
+HOMEPAGE="http://www.gnu.org/software/cflow/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/cflow/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug emacs nls"
+
+RDEPEND="emacs? ( virtual/emacs )
+ nls? ( virtual/libintl virtual/libiconv )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-info-direntry.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ EMACS=no
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile elisp/cflow-mode.el
+ fi
+}
+
+src_install() {
+ default
+ doinfo doc/cflow.info
+
+ if use emacs; then
+ elisp-install ${PN} elisp/cflow-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cflow/files/50cflow-gentoo.el b/dev-util/cflow/files/50cflow-gentoo.el
new file mode 100644
index 00000000000..56a2c8c5d77
--- /dev/null
+++ b/dev-util/cflow/files/50cflow-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; cflow site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'cflow-mode "cflow-mode" nil t)
+(add-to-list 'auto-mode-alist '("\\.cflow\\'" . cflow-mode))
diff --git a/dev-util/cflow/files/cflow-1.4-info-direntry.patch b/dev-util/cflow/files/cflow-1.4-info-direntry.patch
new file mode 100644
index 00000000000..ab7e4956425
--- /dev/null
+++ b/dev-util/cflow/files/cflow-1.4-info-direntry.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/cflow.texi b/doc/cflow.texi
+index dfb1fdf..5dc1d48 100644
+--- a/doc/cflow.texi
++++ b/doc/cflow.texi
+@@ -21,7 +21,7 @@
+ @end direntry
+ @dircategory Emacs
+ @direntry
+-* cflow mode: (cflow)cflow mode. Major mode for visiting cflow charts.
++* cflow mode: (cflow)Emacs. Major mode for visiting cflow charts.
+ @end direntry
+ @end ifinfo
+
diff --git a/dev-util/cflow/metadata.xml b/dev-util/cflow/metadata.xml
new file mode 100644
index 00000000000..1db3f11c857
--- /dev/null
+++ b/dev-util/cflow/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ GNU cflow analyzes a collection of C source files and prints a graph,
+ charting control flow within the program.
+
+ GNU cflow is able to produce both direct and inverted flowgraphs for C
+ sources. Optionally a cross-reference listing can be generated. Two
+ output formats are implemented: POSIX and GNU (extended).
+ </longdescription>
+</pkgmetadata>