summaryrefslogtreecommitdiff
path: root/dev-util/cgdb/cgdb-0.6.8.ebuild
diff options
context:
space:
mode:
authorNado <nado@troglodyte.be>2016-12-05 07:20:33 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2016-12-06 01:10:57 -0500
commit57384cdc2729e44e03bb3d1f30f1996c34f0426d (patch)
tree01cc1e52f4cd6d3bcbdc7b2ee0e1f9eb3299ac6b /dev-util/cgdb/cgdb-0.6.8.ebuild
parent5c5af8244a399423f7c711beefa79bdde5559f51 (diff)
downloadgentoo-57384cdc2729e44e03bb3d1f30f1996c34f0426d.tar.gz
gentoo-57384cdc2729e44e03bb3d1f30f1996c34f0426d.tar.xz
dev-util/cgdb: bump to 0.6.8
The ebuild was simplified and is a copy of the live version. The distfile was changed from zip to tgz Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/cgdb/cgdb-0.6.8.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-0.6.8.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/dev-util/cgdb/cgdb-0.6.8.ebuild b/dev-util/cgdb/cgdb-0.6.8.ebuild
index 8f5ebe82f69..af01627dadc 100644
--- a/dev-util/cgdb/cgdb-0.6.8.ebuild
+++ b/dev-util/cgdb/cgdb-0.6.8.ebuild
@@ -4,18 +4,21 @@
EAPI=6
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://github.com/cgdb/cgdb.git
+ git@github.com:cgdb/cgdb.git"
+else
+ SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
inherit multilib-minimal
DESCRIPTION="A curses front-end for GDB, the GNU debugger"
HOMEPAGE="http://cgdb.github.io/"
-SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.zip -> ${P}.zip"
-
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE=""
-
-S="${WORKDIR}/${P}"
DEPEND="
sys-libs/ncurses:0=
@@ -25,6 +28,8 @@ RDEPEND="
${DEPEND}
sys-devel/gdb"
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README.md TODO )
+
src_prepare() {
default
./autogen.sh || die
@@ -33,12 +38,3 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}
-
-src_compile() {
- multilib-minimal_src_compile
-}
-
-src_install() {
- multilib-minimal_src_install
- dodoc AUTHORS ChangeLog INSTALL NEWS README.md TODO
-}